Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-25718

Issue while editing/styling paragraph in article

    Details

      Description

      Steps to replicate:
      1. Login in to admin panel and create an article
      2.In article section , you have teaser, first paragraph and body
      3.Add paragraph to those fields
      4.Select a paragraph and click Bold
      5.Check the updated styling
      6.Select same paragraph and unbold
      7.This does not work.
      8. You can bold and unbold word in paragraph
      9. Select paragraph and click Bold, italics and underline
      10.Check the updated styling
      11.Now again select paragraph and try unbold, unitalics and no underline.
      12.This does not work
      13.This works when user select a word and select unbold, unitalics and no underline.
      14.Please check the video link http://www.screencast.com/t/czFDIjxIJ0hh for more details

      Expected Result:

      Editor should be able to bold/unbold,italics/unitalics and underline/no underline both paragraph and word.

        Issue Links

          Activity

          Hide
          Piotr Nalepa added a comment -

          ping [~damien.pobel@ez.no]

          Show
          Piotr Nalepa added a comment - ping [~damien.pobel@ez.no]
          Hide
          Damien Pobel (Inactive) added a comment -

          This seems to be CKEditor engine issue happening when the corresponding tag has an id and only if you select the whole element (strong for instance). I reported the issue in the CKEditor tracker.

          Show
          Damien Pobel (Inactive) added a comment - This seems to be CKEditor engine issue happening when the corresponding tag has an id and only if you select the whole element (strong for instance). I reported the issue in the CKEditor tracker .
          Hide
          Damien Pobel (Inactive) added a comment - - edited

          Actually, that's not really a bug in CKEditor so we have to workaround that in our code.
          PR: https://github.com/ezsystems/PlatformUIBundle/pull/577

          Show
          Damien Pobel (Inactive) added a comment - - edited Actually, that's not really a bug in CKEditor so we have to workaround that in our code. PR: https://github.com/ezsystems/PlatformUIBundle/pull/577
          Show
          Damien Pobel (Inactive) added a comment - Merged to master in https://github.com/ezsystems/PlatformUIBundle/commit/3847177b1a86649053423ecb85640b5b77ea18cc Merged to 1.3 in https://github.com/ezsystems/PlatformUIBundle/commit/a8b4feb15ca8fc9d5d74e5496d511d8e9daee61f
          Hide
          Rui Silva (Inactive) added a comment -

          Tested and approved by QA for 16.04 and master.

          Show
          Rui Silva (Inactive) added a comment - Tested and approved by QA for 16.04 and master.

            People

            • Assignee:
              Unassigned
              Reporter:
              Sweta Pandey
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: