Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-25621

eZ Content Staging: content that is not in main language is not synced

    Details

      Description

      Steps to reproduce:

      Prepare the environment:
      • Prepare two eZ Publish 5.4 installations, fully updated via composer. One will be your source server, and the other will be the target server;
      • On both installations, the main language is eng-GB, and there is also fre-FR;
      • Install eZ Content Staging LS 5.3 on both installations;

      Ref: https://doc.ez.no/Extensions/eZ-Publish-extensions/eZ-Content-Staging/eZ-Content-Staging-LS-5.3/Installation

      Reproduce the issue:

      1. Source: create a new content in fre-FR (please note main language is eng-GB on both installations);
      2. Source: sync it. The following message is displayed:

      Event synchronisation action results :
      Object 122 succesfully synchronised to feed 54ezdemocs2.com [Event 2]
      

      3. Target: check if the content has been synced. It has not.

      There are no errors in either the source or target installations' error logs.

        Issue Links

          Activity

          Hide
          Joao Inacio (Inactive) added a comment - - edited

          After further investigation, it has been verified that the cause of this issue is a missing siteaccess configuration for the wanted language(s).

          Contentstaging target server uri should use the admin siteaccess, or one with all available languages.
          This could either be done using host match mapping on the target server, or configuring rest.ini and wsproviders.ini uri (in source) to use the correct siteaccess uri.

          This procedure has been documented under https://doc.ez.no/Extensions/eZ-Publish-extensions/eZ-Content-Staging/eZ-Content-Staging-LS-5.3/Known-limitations

          Show
          Joao Inacio (Inactive) added a comment - - edited After further investigation, it has been verified that the cause of this issue is a missing siteaccess configuration for the wanted language(s). Contentstaging target server uri should use the admin siteaccess, or one with all available languages. This could either be done using host match mapping on the target server, or configuring rest.ini and wsproviders.ini uri (in source) to use the correct siteaccess uri. This procedure has been documented under https://doc.ez.no/Extensions/eZ-Publish-extensions/eZ-Content-Staging/eZ-Content-Staging-LS-5.3/Known-limitations

            People

            • Assignee:
              Unassigned
              Reporter:
              Nuno Oliveira (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: