Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-25345

Numeric character references not seen as literal in "literal text" in OE 5.4

    Details

    • Type: Bug Bug
    • Status: Confirmed
    • Priority: High High
    • Resolution: Unresolved
    • Affects Version/s: 5.4.5
    • Fix Version/s: QA tracked issues
    • Labels:
    • Environment:

      Operating System: Debian 8
      PHP Version: 5.6.14-0+deb8u1
      Database and version: Mysql 5.5.46-0+deb8u1
      Browser (and version): Firefox 43

      Description

      Pasting text with numeric character references (decimal * or hexadecimal ä) into a literal block will be shown as their interpreted values. They should be shown literally (unless the literal block is a custom one which outputs its content without escaping).

      Steps to reproduce:
      1. Create any content object with an XML block (example, folder, article)
      2. Add a literal block into it
      3. Paste text like the following: *
      4. Publish, and access your content

      The text will appear as * and not as *

      This affects 5.4, but not 5.3.

        Issue Links

          Activity

          Hide
          Gunnstein Lye added a comment -

          Paulo Nunes This is weird. The bug occurs only when OE is enabled. Yet the differences in OE between 5.3 and 5.4 are very small, and downgrading OE to 5.3 on a 5.4 installation doesn't affect the bug. Any idea?

          Show
          Gunnstein Lye added a comment - Paulo Nunes This is weird. The bug occurs only when OE is enabled. Yet the differences in OE between 5.3 and 5.4 are very small, and downgrading OE to 5.3 on a 5.4 installation doesn't affect the bug. Any idea?
          Hide
          Paulo Nunes (Inactive) added a comment -

          Gunnstein Lye Yes, it's weird. But I have no idea why. To test this, I just installed a clean version of 5.3 and 5.4 and upgraded them before doing the respectively tests.

          Show
          Paulo Nunes (Inactive) added a comment - Gunnstein Lye Yes, it's weird. But I have no idea why. To test this, I just installed a clean version of 5.3 and 5.4 and upgraded them before doing the respectively tests.
          Hide
          Gunnstein Lye added a comment -

          5.3.0 (not updated) also behaves like 5.4. The plot thickens...

          Show
          Gunnstein Lye added a comment - 5.3.0 (not updated) also behaves like 5.4. The plot thickens...

            People

            • Assignee:
              Unassigned
              Reporter:
              Paulo Nunes (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 6 hours, 30 minutes
                6h 30m