Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-25096

Documentation: InvalidSearchEngine exception after upgrade to 5.4.5 (legacy search)

    XMLWordPrintable

    Details

      Description

      When upgrading to eZ Publish 5.4.5 using composer update, the following exception is thrown (on cache clear):

        [eZ\Bundle\EzPublishCoreBundle\ApiLoader\Exception\InvalidSearchEngine]
        Invalid search engine 'legacy'. Could not find a service tagged as 'ezpublish.searchEngine' with alias 'legacy'.
      

      The solution appears to be adding EzPublishLegacySearchEngineBundle() to the kernel's registerBundles() method, however this is not mentioned in https://doc.ez.no/display/EZP/5.4.x+Update+Instructions

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            joao.inacio-obsolete@ez.no Joao Inacio (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: