Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-24962

Using mail in form <mail>@<domain> passes field validation but raises an error when publishing

    XMLWordPrintable

    Details

      Description

      When I use an object that has an email attribute, the use of email@domain passes field validation, but raises an error when publishing the object.

      email field validation publishing action
      test@domain Pass fails
      test@domain.com pass pass
      Steps to reproduce
      • Create a content type with an email attribute
      • Create an object from previous content type
      • on the email field, use "test@domain"
      • Publish the object

      We have an error "An error occurred while publishing the draft"

      The request/response I had

      Remote Address:127.0.0.1:80
      Request URL:http://ezp5.paulo/api/ezp/v2/content/objects/153/versions/2
      Request Method:PATCH
      Status Code:400 Bad Request
      
      {"ErrorMessage":{"_media-type":"application\/vnd.ez.api.ErrorMessage+json","errorCode":400,"errorMessage":"Bad Request","errorDescription":"Content fields did not validate"}}
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              paulo.nunes-obsolete@ez.no Paulo Nunes (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 0 minutes
                  0m
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 3 hours
                  3h