Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-24657

Removing content of the Image datatype in a content object doesn't sync after content staging

    XMLWordPrintable

    Details

      Description

      Steps to reproduce:

      Prepare the environment:
      • Prepare two eZ Publish 4.7 installations, fully patched. One will be the source server, and the other will be the target server;
      • Install eZ Content Staging 4.7.1 on both installations. More details here:

      https://doc.ez.no/Extensions/eZ-Publish-extensions/eZ-Content-Staging/eZ-Content-Staging-1.x/Installation

      Notes:

      • When installing eZ Content Staging 4.7.1 in the source server, make sure to use on contentstagingsource.ini.append.php:
      TransportClass=eZRestApiEmbeddedClientStagingTransport471
      
      • Also make sure that on wsproviders.ini.append.php the 'providerUri' setting points to v2, not v1:
      ...
      providerUri=http://target_server.com/api/contentstaging/v2/
      ...
      
      Reproduce the issue:

      1. Create a new content object (from 'Image' content Class);
      2. Fill in all the required fields, and make sure to fill in the image attribute with an image;
      3. Publish the content object, then sync it to the target instance;
      4. Edit the content object, remove the image by clicking on "Delete Image" button;
      5. Publish the content object, then sync it to the target instance;
      6. On the target instance, open the synced object: the original image is still there.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            nuno.oliveira-obsolete@ez.no Nuno Oliveira (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: