Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-24622

Legacy Bridge error, and ezsetup + admin interface without CSS on master

    Details

      Description

      Legacy Bridge error, and ezsetup + admin interface without CSS on master

      Steps to reproduce:

      1. Install a master:

      php -d memory_limit=-1 composer.phar create-project --prefer-source ezsystems/ezplatform ezpublish5 dev-master
      

      2. After the previous command has finished executing, run:

      php ezpublish/console ezplatform:install --env prod demo-clean
      

      3. Run the setfacls and asset dump commands:

      sudo setfacl -R -m u:apache:rwx -m u:apache:rwx ezpublish/{cache,logs,config,sessions} web
      sudo setfacl -dR -m u:apache:rwx -m u:`whoami`:rwx ezpublish/{cache,logs,config} web
      php ezpublish/console assets:install --symlink web
      php ezpublish/console ezpublish:legacy:assets_install --symlink web
      php ezpublish/console assetic:dump --env=prod web
      

      4. Install legacy bridge, following the steps at:
      https://doc.ez.no/display/EZP/Installing+eZ+Publish+Legacy+on+top+of+eZ+Platform
      and applying the changes to EzPublishKernel.php reported at:
      https://jira.ez.no/browse/EZP-24109

      On fetching the legacy-bridge, for starters, the following error occurs:

       [InvalidArgumentException]
        The target directory "web" does not exist.
       
      assets:install [--symlink] [--relative] [--] [<target>]
       
      Script Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installAssets handling the post-update-cmd event terminated with an exception
       
        [RuntimeException]
        An error occurred when executing the "'assets:install --symlink --relative '\''web'\'''" command.
       
      require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-update] [--update-no-dev] [--update-with-dependencies] [--ignore-platform-reqs] [--sort-packages] [packages1] ... [packagesN]
      

      Continuing the process further:
      5. Manually running the setfacls again (for legacy):

      sudo setfacl -R -m u:apache:rwx -m u:apache:rwx ezpublish/{cache,logs,config,sessions} ezpublish_legacy/{design,extension,settings,var} web
      sudo setfacl -dR -m u:apache:rwx -m u:`whoami`:rwx ezpublish/{cache,logs,config} ezpublish_legacy/{design,extension,settings,var} web
      

      6. Running first:

      php ezpublish/console assetic:dump --env=prod web
      

      and only then:

      php ezpublish/console assets:install --symlink web
      php ezpublish/console ezpublish:legacy:assets_install --symlink web
      

      doesn't result in an error on the latter two commands, though..

      7. Running composer update;

      8. Clear caches;

      9. Access ezsetup:

      http://<my_virtualhost>/ezsetup
      

      and I see the setup wizard without any CSS's.
      I can proceed with it though, but at the end, the legacy admin interface will, expectedly, also have nno CSS's

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Rui Silva (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated: