Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-24532

As an editor, I want to be able to add some elements to the RichText editor with a dedicated toolbar

    Details

    • Type: Story Story
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2015.07
    • Component/s: None
    • Labels:
      None

      Issue Links

        Activity

        Damien Pobel (Inactive) created issue -
        Damien Pobel (Inactive) made changes -
        Field Original Value New Value
        Epic Link EZP-22949 [ 11445 ]
        Damien Pobel (Inactive) made changes -
        Status Open [ 1 ] Confirmed [ 10037 ]
        Damien Pobel (Inactive) made changes -
        Status Confirmed [ 10037 ] Backlog [ 10000 ]
        Damien Pobel (Inactive) made changes -
        Status Backlog [ 10000 ] InputQ [ 10001 ]
        Damien Pobel (Inactive) made changes -
        Assignee Damien Pobel [ damien.pobel@ez.no ]
        Damien Pobel (Inactive) made changes -
        Status InputQ [ 10001 ] Development [ 3 ]
        Damien Pobel (Inactive) made changes -
        Status Development [ 3 ] Development Review [ 10006 ]
        Show
        Damien Pobel (Inactive) added a comment - PR: https://github.com/ezsystems/PlatformUIBundle/pull/287
        Damien Pobel (Inactive) made changes -
        Link This issue relates to EZP-24721 [ EZP-24721 ]
        Damien Pobel (Inactive) made changes -
        Link This issue relates to EZP-24723 [ EZP-24723 ]
        Hide
        Damien Pobel (Inactive) added a comment - - edited

        Merged in master in https://github.com/ezsystems/PlatformUIBundle/commit/265a90a419daff3d817344926b0dac184b5fefb9

        But it's not completely working yet until we upgrade to AlloyEditor 0.5 in EZP-24712

        Show
        Damien Pobel (Inactive) added a comment - - edited Merged in master in https://github.com/ezsystems/PlatformUIBundle/commit/265a90a419daff3d817344926b0dac184b5fefb9 But it's not completely working yet until we upgrade to AlloyEditor 0.5 in EZP-24712
        Damien Pobel (Inactive) made changes -
        Link This issue relates to EZP-24712 [ EZP-24712 ]
        Damien Pobel (Inactive) made changes -
        Status Development Review [ 10006 ] Documentation Review done [ 10011 ]
        Assignee Damien Pobel [ damien.pobel@ez.no ]
        Rui Silva (Inactive) made changes -
        Status Documentation Review done [ 10011 ] QA [ 10008 ]
        Damien Pobel (Inactive) made changes -
        Fix Version/s 2015.07 [ 14280 ]
        Hide
        Rui Silva (Inactive) added a comment - - edited

        [~damien.pobel@ez.no], when I click the "Add content" icon, no icon displaying "h1" shows up, like in your screencast.
        I managed to make it show up twice or thrice I don't have any idea how, but I can't make it show up on purpose by clicking "Add content", and I don't have any console errors on this, on Firefox 36.0.
        Also, when popup icons show, only the "h1" shows up and not the four icons as on your screencast.
        Also, minor glitch I suppose: if I position my cursor at the beginning of the richtext box and I press Delete to delete text and continue, I can eventually delete the "Add content" icon itself.

        Show
        Rui Silva (Inactive) added a comment - - edited [~damien.pobel@ez.no] , when I click the "Add content" icon, no icon displaying "h1" shows up, like in your screencast. I managed to make it show up twice or thrice I don't have any idea how, but I can't make it show up on purpose by clicking "Add content", and I don't have any console errors on this, on Firefox 36.0. Also, when popup icons show, only the "h1" shows up and not the four icons as on your screencast. Also, minor glitch I suppose: if I position my cursor at the beginning of the richtext box and I press Delete to delete text and continue, I can eventually delete the "Add content" icon itself.
        Rui Silva (Inactive) made changes -
        Flagged Impediment [ 10000 ]
        Hide
        Damien Pobel (Inactive) added a comment - - edited

        Indeed, there are some issue in Firefox, can you please create a specific linked but for that. In Chrome, it works better normally.
        It seems like you are mixing the screenshot (the image) and the screencast (the video). The screenshot is taken from the spec, so this is what will be implemented when everything is finished but of course we are at the very beginning so what the patch does is visible in the screencast and there's only the heading button as stated in the pull request description.
        Being able to remove the "Add content" is clearly not a minor glitch, please report a separate issue.
        (and please stop creating restricted comment, there's nothing secret in such comment)

        Show
        Damien Pobel (Inactive) added a comment - - edited Indeed, there are some issue in Firefox, can you please create a specific linked but for that. In Chrome, it works better normally. It seems like you are mixing the screenshot (the image) and the screencast (the video). The screenshot is taken from the spec, so this is what will be implemented when everything is finished but of course we are at the very beginning so what the patch does is visible in the screencast and there's only the heading button as stated in the pull request description. Being able to remove the "Add content" is clearly not a minor glitch, please report a separate issue. (and please stop creating restricted comment, there's nothing secret in such comment)
        Rui Silva (Inactive) made changes -
        Link This issue testing discovered EZP-24735 [ EZP-24735 ]
        Rui Silva (Inactive) made changes -
        Link This issue testing discovered EZP-24736 [ EZP-24736 ]
        Hide
        Rui Silva (Inactive) added a comment -

        Tested and approved by QA for master.

        Show
        Rui Silva (Inactive) added a comment - Tested and approved by QA for master.
        Rui Silva (Inactive) made changes -
        Assignee Rui Silva [ rui.silva@ez.no ]
        Status QA [ 10008 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Alex Schuster made changes -
        Workflow EZ* Development Workflow [ 94678 ] EZEE Development Workflow [ 124908 ]
        Alex Schuster made changes -
        Workflow EZEE Development Workflow [ 124908 ] EZEE and EZP Story Workflow [ 127974 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Confirmed Confirmed
        7s 1 damien.pobel@ez.no 25/Jun/15 5:21 PM
        Confirmed Confirmed Backlog Backlog
        1s 1 damien.pobel@ez.no 25/Jun/15 5:21 PM
        Backlog Backlog InputQ InputQ
        3d 15h 56m 1 damien.pobel@ez.no 29/Jun/15 9:17 AM
        InputQ InputQ Development Development
        21d 20m 1 damien.pobel@ez.no 20/Jul/15 9:38 AM
        Development Development Development Review Development Review
        31d 4h 52m 1 damien.pobel@ez.no 20/Aug/15 2:31 PM
        Development Review Development Review Documentation Review done Documentation Review done
        4d 21h 13m 1 damien.pobel@ez.no 25/Aug/15 11:44 AM
        Documentation Review done Documentation Review done QA QA
        33m 12s 1 rui.silva@ez.no 25/Aug/15 12:17 PM
        QA QA Closed Closed
        22h 10m 1 rui.silva@ez.no 26/Aug/15 10:27 AM

          People

          • Assignee:
            Unassigned
            Reporter:
            Damien Pobel (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: