Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-24491

eZOE: "go back" button for custom tags with custom attributes of type "link" doesn't work

    Details

      Description

      When using custom tags with custom attributes of type "link", when you open the custom tag popup window, there will be three buttons, "Search", "Browse" and "Bookmarks". When you click in any of those buttons, you will be re-directed to a suitable "Properties" area. That area contains a "go back" button, but when you click on it, you will remain on the "properties" area, which will be rendered empty (see screenshots).

      Steps to reproduce:

      1. Create a custom tag that contains a custom attribute of type "link". Called it "stvdbutton". Use attached "content.ini.append.php" and "ezoe_attributes.ini.append.php" files as reference;
      2. Create or edit a content that contains an XML block field (used Article/Body);
      3. On the XML block field, click "Insert custom tag" button;
      4. Select "stvdbutton" custom tag;
      5. Click on either "Search", "Browse" or "Bookmarks" button;
      6. Try to go back by clicking on the "go back" button. You will remain on the now empty "Properties" area (see screenshots).

      1. content.ini.append.php
        0.1 kB
        Nuno Oliveira
      2. ezoe_attributes.ini.append.php
        0.1 kB
        Nuno Oliveira
      1. 2 - browse.JPG
        25 kB
      2. 2 - select 2.JPG
        17 kB

        Issue Links

          Activity

          Nuno Oliveira (Inactive) created issue -
          Nuno Oliveira (Inactive) made changes -
          Field Original Value New Value
          Status Open [ 1 ] Confirmed [ 10037 ]
          Nuno Oliveira (Inactive) made changes -
          Attachment 2 - browse.JPG [ 19495 ]
          Attachment 2 - select 2.JPG [ 19496 ]
          Attachment content.ini.append.php [ 19497 ]
          Attachment ezoe_attributes.ini.append.php [ 19498 ]
          Nuno Oliveira (Inactive) made changes -
          Summary eZOE: "go back" button for custom tags with custom attributes of type "link" don't work eZOE: "go back" button for custom tags with custom attributes of type "link" doesn't work
          Ricardo Correia (Inactive) made changes -
          Status Confirmed [ 10037 ] InputQ [ 10001 ]
          Damien Pobel (Inactive) made changes -
          Assignee Damien Pobel [ damien.pobel@ez.no ]
          Show
          Yannick Roger (Inactive) added a comment - This is fixed by: https://github.com/peec/ezpublish-legacy/commit/3196e5ff6cb26d2367698466b7a47b7df3008a57
          Yannick Roger (Inactive) made changes -
          Link This issue relates to EZP-23073 [ EZP-23073 ]
          Yannick Roger (Inactive) made changes -
          Status InputQ [ 10001 ] Development [ 3 ]
          Assignee Damien Pobel [ damien.pobel@ez.no ] Yannick Roger [ yannick.roger@ez.no ]
          Yannick Roger (Inactive) made changes -
          Status Development [ 3 ] Development Review [ 10006 ]
          Yannick Roger (Inactive) made changes -
          Status Development Review [ 10006 ] Documentation Review done [ 10011 ]
          Fix Version/s 5.3.6 [ 14185 ]
          Assignee Yannick Roger [ yannick.roger@ez.no ]
          Rui Silva (Inactive) made changes -
          Status Documentation Review done [ 10011 ] QA [ 10008 ]
          Hide
          Rui Silva (Inactive) added a comment -

          Tested and approved by QA for 5.3 and master.

          Show
          Rui Silva (Inactive) added a comment - Tested and approved by QA for 5.3 and master.
          Rui Silva (Inactive) made changes -
          Assignee Rui Silva [ rui.silva@ez.no ]
          Status QA [ 10008 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Alex Schuster made changes -
          Workflow EZ* Development Workflow [ 86022 ] EZEE Development Workflow [ 124883 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Confirmed Confirmed
          3m 13s 1 nuno.oliveira@ez.no 10/Jun/15 10:22 PM
          Confirmed Confirmed InputQ InputQ
          45m 47s 1 ricardo.correia@ez.no 10/Jun/15 11:08 PM
          InputQ InputQ Development Development
          13d 15h 53m 1 yannick.roger@ez.no 24/Jun/15 3:02 PM
          Development Development Development Review Development Review
          3s 1 yannick.roger@ez.no 24/Jun/15 3:02 PM
          Development Review Development Review Documentation Review done Documentation Review done
          17s 1 yannick.roger@ez.no 24/Jun/15 3:02 PM
          Documentation Review done Documentation Review done QA QA
          1m 17s 1 rui.silva@ez.no 24/Jun/15 3:03 PM
          QA QA Closed Closed
          1h 19m 1 rui.silva@ez.no 24/Jun/15 4:23 PM

            People

            • Assignee:
              Unassigned
              Reporter:
              Nuno Oliveira (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: