Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-24417

Trying to install a legacy extension using composer raises a RuntimeException

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 5.3.5.1
    • Fix Version/s: QA tracked issues
    • Labels:
      None
    • Environment:

      Operating System: CentOS 6.5 x64
      PHP Version: 5.3.3
      Database and version: Mysql 5.1.73
      Browser (and version): Firefox 37

      Description

      Trying to install a legacy extension in 5.3.x, gives the

      [RuntimeException]
        The lock file does not contain require-dev information, run install with the --no-dev option or run update to install those packages.
      

      Steps to Reproduce

      – Untar 5.3.0
      – Make an installation running ezsetup
      – Try to install ezfind (for instance) ( php composer.phar require --prefer-dist ezsystems/ezfind-ls:5.3.* ) as referred in documentation

      The above error appears.
      To avoid it, I removed composer.lock and re-tried the above command and the error no longer appeared.

      Even if I do an upgrade to 5.3.5, the exception still occurs.

        Activity

        Hide
        Bertrand Dunogier added a comment - - edited

        Or you could add --no-dev, as instructed by the error message.

        Is there a particular documentation that explicitly says we should not use --no-dev ? It might be that we haven't updated the installation instructions to include --no-dev.

        Show
        Bertrand Dunogier added a comment - - edited Or you could add --no-dev , as instructed by the error message. Is there a particular documentation that explicitly says we should not use --no-dev ? It might be that we haven't updated the installation instructions to include --no-dev.
        Hide
        Paulo Nunes (Inactive) added a comment - - edited

        Adding --no-dev was also tried:

        $ php composer.phar require --prefer-dist --no-dev ezsystems/ezfind-ls:5.3.*
         
          [RuntimeException]
          The "--no-dev" option does not exist.
         
        require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-update] [--update-no-dev] [--update-with-dependencies] [--ignore-platform-reqs] [--sort-packages] [packages1] ... [packagesN]
        

        Show
        Paulo Nunes (Inactive) added a comment - - edited Adding --no-dev was also tried: $ php composer.phar require --prefer-dist --no-dev ezsystems/ezfind-ls:5.3.*   [RuntimeException] The "--no-dev" option does not exist.   require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-update] [--update-no-dev] [--update-with-dependencies] [--ignore-platform-reqs] [--sort-packages] [packages1] ... [packagesN]
        Hide
        Paulo Nunes (Inactive) added a comment -

        If I use --update-no-dev, then the extension installation is done without errors.

        ie,

        php composer.phar require --prefer-dist --update-no-dev ezsystems/ezfind-ls:5.3.*
        

        Show
        Paulo Nunes (Inactive) added a comment - If I use --update-no-dev , then the extension installation is done without errors. ie, php composer.phar require --prefer-dist --update-no-dev ezsystems/ezfind-ls:5.3.*
        Hide
        Bertrand Dunogier added a comment -

        I was gonna suggest --update-no-dev indeed.

        Show
        Bertrand Dunogier added a comment - I was gonna suggest --update-no-dev indeed.
        Hide
        Paulo Nunes (Inactive) added a comment -

        This problem affects 5.3 and 5.4 versions if we use the correspondent install instructions (that don't refer --update-no-dev).
        The question is that if the documentation should be updated to reflect this.

        Show
        Paulo Nunes (Inactive) added a comment - This problem affects 5.3 and 5.4 versions if we use the correspondent install instructions (that don't refer --update-no-dev ). The question is that if the documentation should be updated to reflect this.
        Hide
        Paulo Nunes (Inactive) added a comment -

        I'll close this issue, since 5.3 extensions installation document and 5.4 extensions installation document have been updated to include "--update-no-dev" .

        Show
        Paulo Nunes (Inactive) added a comment - I'll close this issue, since 5.3 extensions installation document and 5.4 extensions installation document have been updated to include "--update-no-dev" .

          People

          • Assignee:
            Unassigned
            Reporter:
            Paulo Nunes (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: