Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-24153

eZ Recommendation ( PECL HTTP ) Extension won't work and PHP 5.6

    Details

      Description

      eZ Recommendation extension requirements page is not updated and indicates the extension requires ezphttprequest extensio​n, namely 1.x since 2.x will not work because of an API change.

      This requirement means that ezphttprequest and the dependent extensions like eZRecommendation won't work with PHP 5.6, and they should.

        Activity

        Hide
        André Rømcke added a comment -

        Changed issue to improvement as we don't Professionally/officially support PHP 5.6:
        https://doc.ez.no/display/EZP/Requirements+5.4

        Show
        André Rømcke added a comment - Changed issue to improvement as we don't Professionally/officially support PHP 5.6: https://doc.ez.no/display/EZP/Requirements+5.4
        Hide
        André Rømcke added a comment - - edited

        Relevant issue from QA during 5.4 certification: EZP-23588
        TL;DR; Certification was in the end done by downgrading pecl_http to 1.x as stated in our requirements, so current state is basically that the ezma and ezrecommendation extensions are not supported on PHP 5.6 (where Pecl 1.x does not work), so marking this a documentation issue and moving it to doc.

        DOC: Please add a mention on eZ Marketing Automation and eZ Recommendation documentation that these extension are not supported on PHP 5.6 because of conflicting pecl_http requirement.

        Show
        André Rømcke added a comment - - edited Relevant issue from QA during 5.4 certification: EZP-23588 TL;DR; Certification was in the end done by downgrading pecl_http to 1.x as stated in our requirements, so current state is basically that the ezma and ezrecommendation extensions are not supported on PHP 5.6 (where Pecl 1.x does not work), so marking this a documentation issue and moving it to doc. DOC: Please add a mention on eZ Marketing Automation and eZ Recommendation documentation that these extension are not supported on PHP 5.6 because of conflicting pecl_http requirement.
        Show
        Sarah Haïm-Lubczanski (Inactive) added a comment - - edited eZ Marketing Automation : https://doc.ez.no/display/EZMA/Installation eZ Recommendation : https://doc.ez.no/display/EZRECO/Requirements https://doc.ez.no/display/EZRECO/Note+on+backwards+compatibility
        Hide
        Rui Silva (Inactive) added a comment -

        [~sarah.haim-lubczanski@ez.no], can you please update the documentation on the correct links as provided by Eduardo, instead of creating new parallel doc pages?
        EZReco doc updates on:
        https://doc.ez.no/Extensions/eZ-Publish-extensions/eZ-Recommendation/Installation/Requirements
        instead of:
        https://doc.ez.no/display/EZRECO/Requirements
        And perhaps create a new for EZMA also on:
        https://doc.ez.no/Extensions/eZ-Publish-extensions
        with the same structure as EZRECO.

        Show
        Rui Silva (Inactive) added a comment - [~sarah.haim-lubczanski@ez.no] , can you please update the documentation on the correct links as provided by Eduardo, instead of creating new parallel doc pages? EZReco doc updates on: https://doc.ez.no/Extensions/eZ-Publish-extensions/eZ-Recommendation/Installation/Requirements instead of: https://doc.ez.no/display/EZRECO/Requirements And perhaps create a new for EZMA also on: https://doc.ez.no/Extensions/eZ-Publish-extensions with the same structure as EZRECO.
        Hide
        Rui Silva (Inactive) added a comment -

        [~sarah.haim-lubczanski@ez.no], do not change it according to my previous suggestion afterall, since as we talked via Skype, the location that Eduardo reported on the description of this jira is meant for Legacy versions extensions, and not the latest versions.
        Since this is a limitation on a latest version of php, these spaces where you edited are reserved for overall info on the extensions, and so this information makes sense NOT on the space Eduardo referred but where you edited precisely.

        Show
        Rui Silva (Inactive) added a comment - [~sarah.haim-lubczanski@ez.no] , do not change it according to my previous suggestion afterall, since as we talked via Skype, the location that Eduardo reported on the description of this jira is meant for Legacy versions extensions, and not the latest versions. Since this is a limitation on a latest version of php, these spaces where you edited are reserved for overall info on the extensions, and so this information makes sense NOT on the space Eduardo referred but where you edited precisely.
        Hide
        Rui Silva (Inactive) added a comment -

        Tested and approved by QA.

        Show
        Rui Silva (Inactive) added a comment - Tested and approved by QA.

          People

          • Assignee:
            Unassigned
            Reporter:
            Eduardo Fernandes (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: