Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-23752

Strict standards error with Symfony 2.6

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 2014.11, 5.4.0
    • Fix Version/s: 2015.01, 5.4.1
    • Component/s: Platform stack
    • Labels:
      None

      Description

      Using Symfony 2.6 and with a custom controller extending eZ\Bundle\EzPublishCoreBundle\Controller, you stumble upon the following error:

      Strict Standards: Declaration of eZ\Bundle\EzPublishCoreBundle\Controller::isGranted() should be compatible with Symfony\Bundle\FrameworkBundle\Controller\Controller::isGranted($attributes, $object = NULL) in /home/mysite/www/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishCoreBundle/Controller.php on line 16
      

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            jerome.vieilledent-obsolete@ez.no Jérôme Vieilledent (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: