Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-23725

Wrong path_identification_string when editing in frontend siteaccess using PathPrefix and RootNode

    XMLWordPrintable

    Details

      Description

      Steps to reproduce:

      1. Create the following content structure:

      Home				(node_id: 2)
      	Tests			(Folder, node_id: 120)
      		News		(Frontpage, node_id: 142)
      

      2. Check original path_identification_path of the "News" frontpage in database:

      mysql> select contentobject_id, node_id, path_string, path_identification_string  from ezcontentobject_tree where node_id = 142;
      +------------------+---------+---------------+----------------------------+
      | contentobject_id | node_id | path_string   | path_identification_string |
      +------------------+---------+---------------+----------------------------+
      |              145 |     142 | /1/2/120/142/ | tests/news                 |
      +------------------+---------+---------------+----------------------------+
      1 row in set (0.00 sec)
      

      3. Set "News" frontpage object as root node in ezpublish.yml:

      ezpublish:
          system:
              ezdemo_site_group:
                  content:
                      tree_root:
                          location_id: 142
      

      4. Go to frontpage siteaccess and edit and publish "News" frontpage object;
      5. Check path_identification_path again:

      mysql> select contentobject_id, node_id, path_string, path_identification_string  from ezcontentobject_tree where node_id = 142;
      +------------------+---------+---------------+----------------------------+
      | contentobject_id | node_id | path_string   | path_identification_string |
      +------------------+---------+---------------+----------------------------+
      |              145 |     142 | /1/2/120/142/ | tests/                     |
      +------------------+---------+---------------+----------------------------+
      1 row in set (0.00 sec)
      

      path_identification_string should be "tests/news", but it's just "tests/" instead.

      Notes:

      • This issue has been originally described in EZP-18889;
      • There seems to be a new stack issue here, as location_id property is mapped to RootNode. This should not be done, as it causes issues like these, it should be better to set PathPrefix + RootNodeDepth;
      • Currently, it is only possible to set RootNodeDepth in legacy, there is no way to achieve that in new stack, other than manually changing eZ\Bundle\EzPublishLegacyBundle\LegacyMapper\Configuration->getMultiSiteSettings();
      • Regarding path_identification_string, it seems to be a symptom: it was made obsolete by url alias in version 3.10 and further deprecated with 5.0 by not including it in the Public API. It will be gone from the system in 6.0.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              nuno.oliveira-obsolete@ez.no Nuno Oliveira (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: