Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-23601

Command runcronjobs.php using ezpublish:legacy:script not working properly with hide

    Details

      Description

      When running the command

      $ php ezpublish/console ezpublish:legacy:script runcronjobs.php hide 
      

      on ezpublish root it doesn't produce any errors but it does not works as expected (the Content Type is not hidden) however runnig the command

      $ php runcronjobs.php hide 
      

      inside ezpublish_legacy folder it works as expected.

        Activity

        Hide
        Bertrand Dunogier added a comment -

        Which environment do you use on the web server ? Same as for the command line ?

        Show
        Bertrand Dunogier added a comment - Which environment do you use on the web server ? Same as for the command line ?
        Hide
        Pedro Resende (Inactive) added a comment -

        I'm using in prod, and it's the same for the command line.

        php ezpublish/console ezpublish:legacy:script runcronjobs.php hide --env=prod

        Show
        Pedro Resende (Inactive) added a comment - I'm using in prod, and it's the same for the command line. php ezpublish/console ezpublish:legacy:script runcronjobs.php hide --env=prod
        Hide
        Bertrand Dunogier added a comment -

        The env must be passed before the name of the legacy script.
        Just tried, with a custom class that has name + hide_date, worked both from legacy and through new stack wrapper.

        bertrand@VM2-php55:~/ezp5 (EK-release-5.4)$ php app/console --env=dev ezpublish:legacy:script runcronjobs.php hide
        Running script 'runcronjobs.php' in eZ Publish legacy context
        Using siteaccess  for cronjob
        Running cronjob part 'hide'
        Running cronjobs/hide.php at: 24/11/2014 4:21 pm
        Hiding content of node "Home" (2)
         
        Hiding 1 node(s) of class ezp_23601.
        Hiding node: "Test 1" (521)
         
         
        Completing cronjobs/hide.php at: 24/11/2014 4:21 pm
        Elapsed time: 00:00:00

        Show
        Bertrand Dunogier added a comment - The env must be passed before the name of the legacy script. Just tried, with a custom class that has name + hide_date, worked both from legacy and through new stack wrapper. bertrand@VM2-php55:~/ezp5 (EK-release-5.4)$ php app/console --env=dev ezpublish:legacy:script runcronjobs.php hide Running script 'runcronjobs.php' in eZ Publish legacy context Using siteaccess for cronjob Running cronjob part 'hide' Running cronjobs/hide.php at: 24/11/2014 4:21 pm Hiding content of node "Home" (2)   Hiding 1 node(s) of class ezp_23601. Hiding node: "Test 1" (521)     Completing cronjobs/hide.php at: 24/11/2014 4:21 pm Elapsed time: 00:00:00
        Hide
        Pedro Resende (Inactive) added a comment -

        The issue isn't present on build #44

        Show
        Pedro Resende (Inactive) added a comment - The issue isn't present on build #44

          People

          • Assignee:
            Unassigned
            Reporter:
            Pedro Resende (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: