Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-23573

ez_is_field_empty does not work for a "date and time" field

    XMLWordPrintable

    Details

      Description

      If you have an attribute of the "Date and time" datatype with an identifier "end_date", this check always returns "false".

      Steps to reproduce:

      1. Add a "date and time" attribute to your article class
      2. Create a new article, and leave the "date and time" empty
      3. Add {{ ez_is_field_empty( content, 'end_date' ) }} to your vendor/ezsystems/demobundle/EzSystems/DemoBundle/Resources/views/full/article.html.twig template, considering that "end_date" is the alias of your date time attribute
      4. Navigate to your article from the frontend (eZ Demo)

      It should return "1", but nothing is returned.
      Everything work correctly with the "date" attribute.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ricardo.correia-obsolete@ez.no Ricardo Correia (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 1 day, 7 hours, 45 minutes
                  1d 7h 45m