Details

      Description

      If you edit any content ( here I used an article ) and preview it, the preview will fallback to legacy design.

      Steps to Reproduce

      1. Edit vendor/ezsystems/demobundle/EzSystems/DemoBundle/Resources/views/full/article.html.twig and change the h1 line

        <h1># TWIG: {{ ez_render_field( content, 'title' ) }} #</h1>
        

      2. Edit ezpublish_legacy/extension/ezdemo/design/ezdemo/override/templates/full/article.tpl and change the h1 line

        <h1># LEGACY:  {$node.data_map.title.content|wash()} #</h1>
        

      3. Clear the caches

      In frontend

      1. Make sure your frontend is not in legacy_mode.
      2. Login in frotend
      3. Create the new "Article #001" article
      4. Open the published "Article #001"
      5. Make sure you see "# TWIG:" in the article header
      6. Edit "Article #001" and preview it
      7. Confirm now you will see "# LEGACY:" in the article header

        Issue Links

          Activity

          Show
          Joao Inacio (Inactive) added a comment - Fixed in master: https://github.com/ezsystems/ezpublish-kernel/commit/1a5782fff5e3ff7aab25250264df1d81f668e3d3
          Hide
          Paulo Nunes (Inactive) added a comment -

          QA Approved

          tested on eZ Publish 5.3.3 and master

          Show
          Paulo Nunes (Inactive) added a comment - QA Approved tested on eZ Publish 5.3.3 and master

            People

            • Assignee:
              Unassigned
              Reporter:
              Eduardo Fernandes (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: