Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-23379

Symfony error after ezsurvey submit

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: High
    • Resolution: Unresolved
    • Affects Version/s: 5.3.2
    • Fix Version/s: None
    • Labels:
      None

      Description

      I need to use ezsurvey extension in a 5.3 project using the symfony stack.

      Unfortunately, I get an exception when submitting the form :
      "An exception has been thrown during the rendering of a template ("Error when rendering "XXXX" (Status code is 302).") ..."

      Here are the steps I followed to render the ezsurvey legacy template in my twig template :

      • I installed ezsurvey in ezpulish_legacy and created a new survey
      • I created an empty layout ('none') in my project's legacy extension (contains only {$module_result.content})
      • I created an overrride full view twig template for my ezsurvey class in symfony. This template contains the following code :

      {{ render( url( 'ez_legacy',

      {'module_uri': '/layout/set/none/content/view/full/'~location.id}

      ) ) }}

      The ezsurvey form loads fine and I can submit the form (ezsurvey catches errors and displays them in the legacy template with success).

      But I am unable to submit the form as I get the error mentioned above.
      I guess this may have something to do with the $Module->redirectTo( $survey->attribute( 'redirect_submit' ) ); statement in ezsurvey, which doesn't redirect to the correct symfony route, but I don't know how to fix this.

      Thanks for your help.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            supasteevo Steven Bressey
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: