Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-23150

PHP Fatal error: Declaration of eZPublishCorePersistenceLegacyContentHandler_0000000073c4f60d000000004b2c2d5f::load() after upgrading to 5.3.2

    XMLWordPrintable

    Details

      Description

      If you upgrade to 5.3.2 with content in the ezpublish/cache folder you get the following error when running composer

      PHP Fatal error:  Declaration of eZPublishCorePersistenceLegacyContentHandler_0000000073c4f60d000000004b2c2d5f::load() must be compatible with that of eZ\Publish\SPI\Persistence\Content\Handler::load() in /var/www/html/ezp/ezpublish/cache/prod/ezpublishProdProjectContainer.php on line 17101
      Script eZ\Bundle\EzPublishCoreBundle\Composer\ScriptHandler::dumpAssets handling the post-update-cmd event terminated with an exception
      
      
                                                                                               
        [RuntimeException]                                                                     
        An error occurred when executing the "'assetic:dump --env=prod '\''web'\'''" command.  
                                                                                             
      

      Note: If you clear the cache manually before running the update the issue won't be present

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              pedro.resende-obsolete@ez.no Pedro Resende (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: