Details

      Description

      Create a DFS Backend handler for Amazon S3 that can be used through the DFS dispatcher.

      It should handle read/write of binary files, as well as replacement of the assets URLs with the absolute S3 URL.

        Issue Links

          Activity

          Hide
          Bertrand Dunogier added a comment -

          Work-in-progress extension: https://github.com/bdunogier/ez-dfs-amazon-s3.

          Status: works, but isn't up-to-date with the latest interface/extension point changes.

          Show
          Bertrand Dunogier added a comment - Work-in-progress extension: https://github.com/bdunogier/ez-dfs-amazon-s3 . Status: works, but isn't up-to-date with the latest interface/extension point changes.
          Hide
          Eduardo Fernandes (Inactive) added a comment - - edited

          Following ezdfs-fsbackend-dispatcher read me instructions, I tried to install using the following command, but got the error below:

          composer.phar require "ezsystems/ezdfs-fsbackend-dispatcher:1.0@beta"
          


          Problem 1
          The requested package ezsystems/ezdfs-fsbackend-dispatcher could not be found in any version, there may be a typo in the package name.

          I went to https://packagist.org/packages/ezsystems/ezdfs-fsbackend-dispatcher and tried to uncover the correct version, but still get errors.

          composer.phar require "ezsystems/ezdfs-fsbackend-dispatcher:1.0.0-beta3"
          


          [UnexpectedValueException]
          Could not parse version constraint 1.0.0-beta3pwd: Invalid version string "
          1.0.0-beta3pwd"

          Can you tell me the best way to solve this?

          Show
          Eduardo Fernandes (Inactive) added a comment - - edited Following ezdfs-fsbackend-dispatcher read me instructions , I tried to install using the following command, but got the error below: composer.phar require "ezsystems/ezdfs-fsbackend-dispatcher:1.0@beta" Problem 1 The requested package ezsystems/ezdfs-fsbackend-dispatcher could not be found in any version, there may be a typo in the package name. I went to https://packagist.org/packages/ezsystems/ezdfs-fsbackend-dispatcher and tried to uncover the correct version, but still get errors. composer.phar require "ezsystems/ezdfs-fsbackend-dispatcher:1.0.0-beta3" [UnexpectedValueException] Could not parse version constraint 1.0.0-beta3pwd: Invalid version string " 1.0.0-beta3pwd" Can you tell me the best way to solve this?
          Hide
          Bertrand Dunogier added a comment -

          README.md for dispatcher updated. Use ~1.0@beta as the version.

          Show
          Bertrand Dunogier added a comment - README.md for dispatcher updated. Use ~1.0@beta as the version.

            People

            • Assignee:
              Unassigned
              Reporter:
              Bertrand Dunogier
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Agile