Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-22884

Discarding an object creation raises a javascript error

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 5.3-dev
    • Component/s: Misc
    • Labels:
      None
    • Environment:

      Operating System: CentOS 6.5 x64
      PHP Version: 5.3.3
      Database and version: Mysql 5.1.73
      Browser (and version): Firefox 29

      Description

      Hi,

      In BUL tarball, build #1259, in backend, when i discard an object creation, a javascript error window is opened with the error below

      This only happens in firefox (29). In Chrome and IE11 this does not happen.

      Steps

      • create an article (or user). Do not publish
      • Discard the object creation. When asked to confirm the discard, press "ok" button.
      • After the last step, a javascript windows appeard with the error bellow:

      {"error_text":"","content":{"unvalidated-attributes":[],"stored-attributes":{"290":290,"291":291,"292":292,"293":293,"294":294,"295":295,"296":296,"297":297,"298":298,"299":299,"300":300},"valid":true,"message_success":"Draft saved at 3:41 pm","message_ago":"(0 minutes ago)","timestamp":1400506903,"preview":"<div class=\"preview-header\">\n    <h1 class=\"context-title\">\n        <a href=\"#\" class=\"close\">&laquo;&nbsp;Back to the edit form<\/a>\n        <img class=\"transparent-png-icon\" src=\"\/share\/icons\/crystal-admin\/32x32\/mimetypes\/document.png\" width=\"32\" height=\"32\" alt=\"Article\" title=\"Article\" \/>\n        Preview of &lt;New article&gt; in siteaccess\n        <select class=\"no-autosave\">\n                    <option value=\"site\" selected=\"selected\">site<\/option>\n                    <option value=\"eng\">eng<\/option>\n                    <option value=\"ezdemo_site_admin\">ezdemo_site_admin<\/option>\n                <\/select>\n        <img src=\"\/extension\/ezautosave\/design\/standard\/images\/as-loader.gif\" alt=\"Loading...\" style=\"display:none\" id=\"iframe-loader\" \/>\n    <\/h1>\n    <div class=\"context-information\">\n        <p class=\"left preview-warning\">\n            <strong>Warning:<\/strong> <em>following links from the preview will take you to the live version of the website<\/em>\n        <\/p>\n        <p class=\"right translation\">\n            English (United Kingdom)&nbsp;<img src=\"\/share\/icons\/flags\/eng-GB.gif\" width=\"18\" height=\"12\" style=\"vertical-align: middle;\" alt=\"eng-GB\" \/>\n        <\/p>\n        <div class=\"break\"><\/div>\n    <\/div>\n<\/div>\n<iframe src=\"\/ezdemo_site_admin\/content\/versionview\/67\/1\/eng-GB\/site_access\/site\"><\/iframe>\n"}}
      

      Note: Don't know if this is related with EZP-22875

        Issue Links

          Activity

          Paulo Nunes (Inactive) created issue -
          Paulo Nunes (Inactive) made changes -
          Field Original Value New Value
          Link This issue relates to EZP-22875 [ EZP-22875 ]
          Paulo Nunes (Inactive) made changes -
          Description Hi,

          In BUL tarball, build #1259, when i discard an object creation, a javascript error window is opened with the error below

          This only happens in firefox (29). In Chrome and IE11 this does not happen.

          Steps
          - create an article (or user). Do not publish
          - Discard the object creation. When asked to confirm the discard, press "ok" button.
          - After the last step, a javascript windows appeard with the error bellow:

          {noformat}
          {"error_text":"","content":{"unvalidated-attributes":[{"id":"242","identifier":"user_account","name":"User account","description":"The username already exists, please choose another one."}],"stored-attributes":{"240":240,"241":241,"243":243,"244":244,"245":245},"valid":false,"message_success":"Draft saved at 3:22 pm","message_ago":"(0 minutes ago)","timestamp":1400505743,"preview":"<div class=\"preview-header\">\n <h1 class=\"context-title\">\n <a href=\"#\" class=\"close\">&laquo;&nbsp;Back to the edit form<\/a>\n <img class=\"transparent-png-icon\" src=\"\/share\/icons\/crystal-admin\/32x32\/apps\/personal.png\" width=\"32\" height=\"32\" alt=\"User\" title=\"User\" \/>\n Preview of &lt; &gt; in siteaccess\n <select class=\"no-autosave\">\n <option value=\"site\" selected=\"selected\">site<\/option>\n <option value=\"eng\">eng<\/option>\n <option value=\"ezdemo_site_admin\">ezdemo_site_admin<\/option>\n <\/select>\n <img src=\"\/extension\/ezautosave\/design\/standard\/images\/as-loader.gif\" alt=\"Loading...\" style=\"display:none\" id=\"iframe-loader\" \/>\n <\/h1>\n <div class=\"context-information\">\n <p class=\"left preview-warning\">\n <strong>Warning:<\/strong> <em>following links from the preview will take you to the live version of the website<\/em>\n <\/p>\n <p class=\"right translation\">\n English (United Kingdom)&nbsp;<img src=\"\/share\/icons\/flags\/eng-GB.gif\" width=\"18\" height=\"12\" style=\"vertical-align: middle;\" alt=\"eng-GB\" \/>\n <\/p>\n <div class=\"break\"><\/div>\n <\/div>\n<\/div>\n<iframe src=\"\/ezdemo_site_admin\/content\/versionview\/62\/1\/eng-GB\/site_access\/site\"><\/iframe>\n"}}
          {noformat}

          Note: Don't know if this is related with EZP-22875
          Hi,

          In BUL tarball, build #1259, when i discard an object creation, a javascript error window is opened with the error below

          This only happens in firefox (29). In Chrome and IE11 this does not happen.

          Steps
          - create an article (or user). Do not publish
          - Discard the object creation. When asked to confirm the discard, press "ok" button.
          - After the last step, a javascript windows appeard with the error bellow:

          {noformat}
          {"error_text":"","content":{"unvalidated-attributes":[],"stored-attributes":{"290":290,"291":291,"292":292,"293":293,"294":294,"295":295,"296":296,"297":297,"298":298,"299":299,"300":300},"valid":true,"message_success":"Draft saved at 3:41 pm","message_ago":"(0 minutes ago)","timestamp":1400506903,"preview":"<div class=\"preview-header\">\n <h1 class=\"context-title\">\n <a href=\"#\" class=\"close\">&laquo;&nbsp;Back to the edit form<\/a>\n <img class=\"transparent-png-icon\" src=\"\/share\/icons\/crystal-admin\/32x32\/mimetypes\/document.png\" width=\"32\" height=\"32\" alt=\"Article\" title=\"Article\" \/>\n Preview of &lt;New article&gt; in siteaccess\n <select class=\"no-autosave\">\n <option value=\"site\" selected=\"selected\">site<\/option>\n <option value=\"eng\">eng<\/option>\n <option value=\"ezdemo_site_admin\">ezdemo_site_admin<\/option>\n <\/select>\n <img src=\"\/extension\/ezautosave\/design\/standard\/images\/as-loader.gif\" alt=\"Loading...\" style=\"display:none\" id=\"iframe-loader\" \/>\n <\/h1>\n <div class=\"context-information\">\n <p class=\"left preview-warning\">\n <strong>Warning:<\/strong> <em>following links from the preview will take you to the live version of the website<\/em>\n <\/p>\n <p class=\"right translation\">\n English (United Kingdom)&nbsp;<img src=\"\/share\/icons\/flags\/eng-GB.gif\" width=\"18\" height=\"12\" style=\"vertical-align: middle;\" alt=\"eng-GB\" \/>\n <\/p>\n <div class=\"break\"><\/div>\n <\/div>\n<\/div>\n<iframe src=\"\/ezdemo_site_admin\/content\/versionview\/67\/1\/eng-GB\/site_access\/site\"><\/iframe>\n"}}
          {noformat}

          Note: Don't know if this is related with EZP-22875
          Paulo Nunes (Inactive) made changes -
          Description Hi,

          In BUL tarball, build #1259, when i discard an object creation, a javascript error window is opened with the error below

          This only happens in firefox (29). In Chrome and IE11 this does not happen.

          Steps
          - create an article (or user). Do not publish
          - Discard the object creation. When asked to confirm the discard, press "ok" button.
          - After the last step, a javascript windows appeard with the error bellow:

          {noformat}
          {"error_text":"","content":{"unvalidated-attributes":[],"stored-attributes":{"290":290,"291":291,"292":292,"293":293,"294":294,"295":295,"296":296,"297":297,"298":298,"299":299,"300":300},"valid":true,"message_success":"Draft saved at 3:41 pm","message_ago":"(0 minutes ago)","timestamp":1400506903,"preview":"<div class=\"preview-header\">\n <h1 class=\"context-title\">\n <a href=\"#\" class=\"close\">&laquo;&nbsp;Back to the edit form<\/a>\n <img class=\"transparent-png-icon\" src=\"\/share\/icons\/crystal-admin\/32x32\/mimetypes\/document.png\" width=\"32\" height=\"32\" alt=\"Article\" title=\"Article\" \/>\n Preview of &lt;New article&gt; in siteaccess\n <select class=\"no-autosave\">\n <option value=\"site\" selected=\"selected\">site<\/option>\n <option value=\"eng\">eng<\/option>\n <option value=\"ezdemo_site_admin\">ezdemo_site_admin<\/option>\n <\/select>\n <img src=\"\/extension\/ezautosave\/design\/standard\/images\/as-loader.gif\" alt=\"Loading...\" style=\"display:none\" id=\"iframe-loader\" \/>\n <\/h1>\n <div class=\"context-information\">\n <p class=\"left preview-warning\">\n <strong>Warning:<\/strong> <em>following links from the preview will take you to the live version of the website<\/em>\n <\/p>\n <p class=\"right translation\">\n English (United Kingdom)&nbsp;<img src=\"\/share\/icons\/flags\/eng-GB.gif\" width=\"18\" height=\"12\" style=\"vertical-align: middle;\" alt=\"eng-GB\" \/>\n <\/p>\n <div class=\"break\"><\/div>\n <\/div>\n<\/div>\n<iframe src=\"\/ezdemo_site_admin\/content\/versionview\/67\/1\/eng-GB\/site_access\/site\"><\/iframe>\n"}}
          {noformat}

          Note: Don't know if this is related with EZP-22875
          Hi,

          In BUL tarball, build #1259, in backend, when i discard an object creation, a javascript error window is opened with the error below

          This only happens in firefox (29). In Chrome and IE11 this does not happen.

          Steps
          - create an article (or user). Do not publish
          - Discard the object creation. When asked to confirm the discard, press "ok" button.
          - After the last step, a javascript windows appeard with the error bellow:

          {noformat}
          {"error_text":"","content":{"unvalidated-attributes":[],"stored-attributes":{"290":290,"291":291,"292":292,"293":293,"294":294,"295":295,"296":296,"297":297,"298":298,"299":299,"300":300},"valid":true,"message_success":"Draft saved at 3:41 pm","message_ago":"(0 minutes ago)","timestamp":1400506903,"preview":"<div class=\"preview-header\">\n <h1 class=\"context-title\">\n <a href=\"#\" class=\"close\">&laquo;&nbsp;Back to the edit form<\/a>\n <img class=\"transparent-png-icon\" src=\"\/share\/icons\/crystal-admin\/32x32\/mimetypes\/document.png\" width=\"32\" height=\"32\" alt=\"Article\" title=\"Article\" \/>\n Preview of &lt;New article&gt; in siteaccess\n <select class=\"no-autosave\">\n <option value=\"site\" selected=\"selected\">site<\/option>\n <option value=\"eng\">eng<\/option>\n <option value=\"ezdemo_site_admin\">ezdemo_site_admin<\/option>\n <\/select>\n <img src=\"\/extension\/ezautosave\/design\/standard\/images\/as-loader.gif\" alt=\"Loading...\" style=\"display:none\" id=\"iframe-loader\" \/>\n <\/h1>\n <div class=\"context-information\">\n <p class=\"left preview-warning\">\n <strong>Warning:<\/strong> <em>following links from the preview will take you to the live version of the website<\/em>\n <\/p>\n <p class=\"right translation\">\n English (United Kingdom)&nbsp;<img src=\"\/share\/icons\/flags\/eng-GB.gif\" width=\"18\" height=\"12\" style=\"vertical-align: middle;\" alt=\"eng-GB\" \/>\n <\/p>\n <div class=\"break\"><\/div>\n <\/div>\n<\/div>\n<iframe src=\"\/ezdemo_site_admin\/content\/versionview\/67\/1\/eng-GB\/site_access\/site\"><\/iframe>\n"}}
          {noformat}

          Note: Don't know if this is related with EZP-22875
          Paulo Nunes (Inactive) made changes -
          Status Open [ 1 ] Confirmed [ 10037 ]
          André Rømcke made changes -
          Status Confirmed [ 10037 ] InputQ [ 10001 ]
          Paulo Nunes (Inactive) made changes -
          Status InputQ [ 10001 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          André Rømcke made changes -
          Workflow eZ Engineering Scrumban Workflow [ 63292 ] EZ* Development Workflow [ 85055 ]
          Alex Schuster made changes -
          Workflow EZ* Development Workflow [ 85055 ] EZEE Development Workflow [ 123828 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Paulo Nunes (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: