Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-22394

EzXml embed tag issue when rendering several times

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Medium
    • Resolution: Unresolved
    • Affects Version/s: 2013.09
    • Fix Version/s: None
    • Component/s: Field types
    • Environment:

      Ubuntu 12.04 TLS / Apache2 mode_php / PHP 5.3.10

      Description

      When rendering a content several times in a single runtime, a given embed tag will not be updated and the same content is returned each time.

      Looking at "eZ\Publish\Core\FieldType\XmlText\Converter\EmbedToHtml5.php", the first time I render my content, the "render" function returns something like:
      <xml>
      <section><embed><![CDATA[
      MY FIRST EMBED RESULT
      ]]></embed></section>

      And on the second time:
      <xml>
      <section><embed><![CDATA[
      MY FIRST EMBED RESULT
      ]]>
      <![CDATA[
      MY SECOND EMBED RESULT
      ]]></embed></section>

      So I made a dirty fix there waiting for your enlightenment.
      Thanks in advance !

      Romain.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            chlabelek Romain Petit
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: