Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-21631

RoutableFragmentRenderer::generateFragmentUri() not compatible with Symfony 2.3.5

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 5.2-dev, 2013.07
    • Fix Version/s: 5.2-rc1
    • Component/s: Platform stack
    • Labels:
      None

      Description

      With Symfony 2.3.5:

      [Symfony\Component\Debug\Exception\ContextErrorException]
      Runtime Notice: Declaration of eZ\Bundle\EzPublishCoreBundle\Fragment\InlineFragmentRenderer::generateFragmentUri() should be compatible with Symfony\Component\HttpKernel\Fragment\RoutableFragmentRenderer::generateFragmentUri(Symfony\Component\HttpKernel\Controller\ControllerReference $reference, Symfony\Component\HttpFoundation\Request $request, $absolute = false) in /mntraid/jenkins.std/jobs/ezpublish5-ee-bul-tarballs/workspace/source/ezpublish5/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishCoreBundle/Fragment/InlineFragmentRenderer.php line 17

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              andre.romcke@ez.no André Rømcke
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: