Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-20931

No error message when passing a wrong parameter on /content/typegroups

    Details

    • Type: Bug Bug
    • Status: Confirmed
    • Priority: High High
    • Resolution: Unresolved
    • Affects Version/s: Engineering tracked issues, 5.0, 5.1, 5.2
    • Fix Version/s: None
    • Component/s: Platform > REST API v2
    • Labels:

      Description

      When passing a wrong parameter the server ignores it and returns the complete content type group list.
      e.g. .../content/typegroups?identifie=Media
      here an error message should be returned when passing from parameters.

        Activity

        Christian Bacher (Inactive) created issue -
        Damien Pobel (Inactive) made changes -
        Field Original Value New Value
        Security Internal [ 10102 ]
        Damien Pobel (Inactive) made changes -
        Labels rest rest rfs
        Stéphane Diot made changes -
        Assignee Stéphane Diot [ stephane.diot@ez.no ]
        Bertrand Dunogier made changes -
        Labels rest rfs rest
        Bertrand Dunogier made changes -
        Assignee Stéphane Diot [ stephane.diot@ez.no ]
        Bertrand Dunogier made changes -
        Status Open [ 1 ] Confirmed [ 10037 ]
        Bertrand Dunogier made changes -
        Affects Version/s 5.2 [ 12582 ]
        Affects Version/s 5.1 [ 11280 ]
        Affects Version/s 5.0 [ 10300 ]
        André Rømcke made changes -
        Workflow eZ Engineering Scrumban Workflow [ 55827 ] EZ* Development Workflow [ 69910 ]
        Alex Schuster made changes -
        Workflow EZ* Development Workflow [ 69910 ] EZEE Development Workflow [ 108306 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Christian Bacher (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated: