Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-20818

[eZFlow] Adding a source to multimedia carousel throws an missing info error

    Details

      Description

      Adding/editing a source for a multimedia carousel on the ezflow frontpage it will throw the following error (on ezdebug) when "sending for publishing":

      Error: eZFlowPool::insertItems 	May 06 2013 09:42:12
       
      Pool item is missing one of the following information: blockID, objectID, nodeID, priority or timestamp
      

      Steps to reproduce:

      1 - login into ezflow with "Admin" account
      2 - make new folder
        - name: "Test folder"
      3 - make 4 articles
        - name: "Article $number"
        - summary: "Summary of article $number"
        - for the first article upload an image
      4 - edit frontpage
      5 - add a "Multimedia carousel"
        - source: "Test folder"
        - classes: "article"
      6 - send for publishing
      7 - verify on ezdebug redirect the above error
      8 - verify that there is no multimedia carousel on frontpage
      

        Issue Links

          Activity

          Hide
          Patrick Allaert (Inactive) added a comment -
          Show
          Patrick Allaert (Inactive) added a comment - PR available at: https://github.com/ezsystems/ezflow/pull/48
          Show
          Patrick Allaert (Inactive) added a comment - Fixed in: ezflow master: https://github.com/ezsystems/ezflow/commit/47b736b1fdb05b6f2eaf12b5b97472dc8c4dbcaa ezflow 5.1: https://github.com/ezsystems/ezflow/commit/5c893664cc682e854a1976a5703847c09988c4e0
          Hide
          Yannick Roger (Inactive) added a comment -

          Reopening to add a backport for 5.0

          Show
          Yannick Roger (Inactive) added a comment - Reopening to add a backport for 5.0
          Hide
          Paulo Nunes (Inactive) added a comment -

          [~yannick.roger@ez.no] This backport for 5.0 has to be QA'ed.(so as in future situations such as this, please)
          I'll reopen the issue and will move it to QA column.

          Show
          Paulo Nunes (Inactive) added a comment - [~yannick.roger@ez.no] This backport for 5.0 has to be QA'ed.(so as in future situations such as this, please) I'll reopen the issue and will move it to QA column.
          Hide
          Yannick Roger (Inactive) added a comment -

          I had a doubt about it. I thought it might have been done with EZP-21979 . I won't hesitate next time. Thanks

          Show
          Yannick Roger (Inactive) added a comment - I had a doubt about it. I thought it might have been done with EZP-21979 . I won't hesitate next time. Thanks
          Hide
          Paulo Nunes (Inactive) added a comment -

          5.0 tested.
          Approved by QA

          Show
          Paulo Nunes (Inactive) added a comment - 5.0 tested. Approved by QA

            People

            • Assignee:
              Unassigned
              Reporter:
              Marcos Loureiro (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 4 hours
                4h