Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-20796

twig exception in ezdemobundle => ezdemo KO

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Duplicate
    • Affects Version/s: 2013.4
    • Fix Version/s: 5.1
    • Component/s: None
    • Labels:
      None
    • Environment:

      index_dev configured.
      Same error 500 with index.php

      Description

      After a fresh install, twig reports an exception :

      An exception has been thrown during the rendering of a template ("Argument '$path' is invalid: Storage directory not found in var/storage/images/getting-started/selected-features/getting-started-with-ez-publish-5/301-1-eng-US/Getting-Started-with-eZ-Publish-5.jpg") in "

      {% extends "eZDemoBundle::pagelayout.html.twig" %} {% block content %}
      {{ viewResult|raw }} {% endblock %}".
      500 Internal Server Error - Twig_Error_Runtime
      1 linked Exception: InvalidArgumentException ยป

      [2/2] Twig_Error_Runtime: An exception has been thrown during the rendering of a template ("Argument '$path' is invalid: Storage directory not found in var/storage/images/getting-started/selected-features/getting-started-with-ez-publish-5/301-1-eng-US/Getting-Started-with-eZ-Publish-5.jpg") in "{% extends "eZDemoBundle::pagelayout.html.twig" %}
      {% block content %}

      {{ viewResult|raw }}

      {% endblock %}

      ".
      [1/2] InvalidArgumentException: Argument '$path' is invalid: Storage directory not found in var/storage/images/getting-started/selected-features/getting-started-with-ez-publish-5/301-1-eng-US/Getting-Started-with-eZ-Publish-5.jpg

      To prevent the error, I have to comment a line in the DemoController.php, on line 141.

      return $this->render(
      "eZDemoBundle:footer:latest_content.html.twig",
      array(
      //bug ez 2013.4 ?
      //"latestContent" => $this->getRepository()>getSearchService()>findContent( $query )
      "latestContent" => array()
      ),
      $response
      );

      My list is empty, but the website is useable.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              Fiber_Optic Nicolas Lescure
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: