Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-20574

Creating a user with an existing username disables the username field

    Details

      Description

      When creating an user with an already used username, it will disable the username field when we try to submit ("Send for publishing" for admin2, or "Register" for anonymous users).

      Steps to reproduce:
      1 - access admin2 login page
      2 - click on "Register new account" link
      3 - fill the fields with:
             first name: First
             last name: User
             username: test
             password: test
             email: second_email@ez.no
      4 - click on "Ok" button
      5 - verify message "User registered"
      (no need to verify on email)
      6 - click on "Ok" button
      7 - click on "Register new account" link
      8 - fill the fields:
             first name: Second
             last name: User
             username: test
             password: test2
             email: first_email@ez.no
      9 - click on "Ok" button
      10- verify that it wasn't registered
      11- verify message "User account: The username already exists, please choose another one."
      12- verify that username is disabled
      

        Issue Links

          Activity

          Hide
          Marcos Loureiro (Inactive) added a comment -

          This happens also for plain_site (haven't tested the others)

          Show
          Marcos Loureiro (Inactive) added a comment - This happens also for plain_site (haven't tested the others)
          Hide
          Vidar Langseid added a comment - - edited

          Workaround is to start the registration process all-over, downgrading to medium severity

          Show
          Vidar Langseid added a comment - - edited Workaround is to start the registration process all-over, downgrading to medium severity
          Hide
          Joaquim Cavalleri (Inactive) added a comment - - edited

          This in independent of current design and, to an extent, might be related to https://jira.ez.no/browse/EZP-21966.
          The issue here is that when you hit publish, the ezuser row is inserted into the database (verified). So, when has_stored_login (hasStoredLogin()) is verified, it returns true, thus disabling the input field.

          Show
          Joaquim Cavalleri (Inactive) added a comment - - edited This in independent of current design and, to an extent, might be related to https://jira.ez.no/browse/EZP-21966 . The issue here is that when you hit publish, the ezuser row is inserted into the database (verified). So, when has_stored_login ( hasStoredLogin() ) is verified, it returns true, thus disabling the input field.
          Hide
          Yannick Roger (Inactive) added a comment - - edited

          PR: https://github.com/ezsystems/ezpublish-legacy/pull/849
          This PR is not valid anymore.

          This issue will be fixed as a side effect of EZP-21966

          Show
          Yannick Roger (Inactive) added a comment - - edited PR: https://github.com/ezsystems/ezpublish-legacy/pull/849 This PR is not valid anymore. This issue will be fixed as a side effect of EZP-21966
          Hide
          Yannick Roger (Inactive) added a comment -

          Please check out the PR for EZP-21966 it also fixes this issue.

          Show
          Yannick Roger (Inactive) added a comment - Please check out the PR for EZP-21966 it also fixes this issue.
          Hide
          Yannick Roger (Inactive) added a comment - - edited

          This is a side effect of EZP-21966 please apply the fix for EZP-21966

          Show
          Yannick Roger (Inactive) added a comment - - edited This is a side effect of EZP-21966 please apply the fix for EZP-21966
          Hide
          Luca Realdi added a comment -

          Thisproblem perisists in ezpublish-legacy 2015.01.3
          What fix I have to apply?

          Show
          Luca Realdi added a comment - Thisproblem perisists in ezpublish-legacy 2015.01.3 What fix I have to apply?
          Hide
          Sebastian Blank added a comment -

          I think the issue isn't fixed yet.

          Show
          Sebastian Blank added a comment - I think the issue isn't fixed yet.
          Hide
          Jean Fred added a comment -

          hi, I have the same problem in my table ezuser I found many user with the same login and the same email ? who explain that ?

          Show
          Jean Fred added a comment - hi, I have the same problem in my table ezuser I found many user with the same login and the same email ? who explain that ?

            People

            • Assignee:
              Unassigned
              Reporter:
              Marcos Loureiro (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: