Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-20164

"oe" ligature is transformed wrong in URL Aliases

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Low
    • Resolution: Unresolved
    • Affects Version/s: 2012.8, 4.7.0
    • Fix Version/s: None
    • Component/s: Language
    • Labels:
      None

      Description

      This is a late issue but here it is

      Whenever we enter "œ" (oe ligature) in a content object, the corresponding URL Alias contains "ae" (ae ligature) whereas it should be "oe".

      The problem comes from the transformation table which does not map to the correct char.

      Wikipedia page with some related information:
      http://en.wikipedia.org/wiki/%C5%92#.C5.92_in_different_languages

      U+0152 = Π= "OE", not "AE".
      U+0153 = œ = "oe", not "ae".

      more info:
      http://www.fileformat.info/info/unicode/char/0152/index.htm

      from eZ Publish (4.0 stable)/share/transformations/latin.tr:
      <code>
      snip
      latin-exta_transliterate_ascii:
      U+0132 = "IJ"
      U+0133 = "ij"
      U+0138 = "k"
      U+0149 = "'n"
      U+014A = "N"
      U+014B = "n"
      U+0152 = "AE"
      U+0153 = "ae"
      U+017F = "s"
      snip
      </code>

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Tharkun911 Jérémy Poulain
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: