Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-19929

embedding images in ezoe generates PHP warning

    Details

      Description

      When you embed an image to an ezoe field you get this warnings in debug:
      Warning: PHP: E_WARNING
      Oct 30 2012 15:51:44
      json_encode(): Invalid UTF-8 sequence in argument in /var/www/apache2php53/ezp5/ezpublish_testsystem/.run/extension/ezjscore/classes/ezjscajaxcontent.php on line 158

      Steps.
      1. Create an Article
      2. On the body field click insert/edit image
      3. Upload an local image
      4. Before clicking "OK" verify the errors in the New <embed> tag window

      1. Desert.jpg
        826 kB
      2. Koala.jpg
        763 kB
      3. Lighthouse.jpg
        548 kB

        Issue Links

          Activity

          Hide
          Damien Pobel (Inactive) added a comment -

          @Joao: could you attach the images you are using for this test ?

          Show
          Damien Pobel (Inactive) added a comment - @Joao: could you attach the images you are using for this test ?
          Hide
          Damien Pobel (Inactive) added a comment - - edited

          hum I'm still not able to reproduce this issue...

          • Do you set any of the fields before uploading the image ?
          • did you execute this test in a cluster env ?
          Show
          Damien Pobel (Inactive) added a comment - - edited hum I'm still not able to reproduce this issue... Do you set any of the fields before uploading the image ? did you execute this test in a cluster env ?
          Hide
          Damien Pobel (Inactive) added a comment -

          A weird issue.
          It actually happens if display_errors is disabled in the php configuration and if the provided images contains EXIF meta data with non utf8 or binary content...

          Show
          Damien Pobel (Inactive) added a comment - A weird issue. It actually happens if display_errors is disabled in the php configuration and if the provided images contains EXIF meta data with non utf8 or binary content...
          Show
          Damien Pobel (Inactive) added a comment - https://github.com/ezsystems/ezpublish/pull/491
          Show
          Damien Pobel (Inactive) added a comment - Fixed in ezpublish: master: http://github.com/ezsystems/ezpublish/commit/52aaf84aeffa92c01a6688aa4adb80b23af461ad
          Hide
          Joao Pingo (Inactive) added a comment -

          Retested in the new build, with no problems
          Approved by QA

          Show
          Joao Pingo (Inactive) added a comment - Retested in the new build, with no problems Approved by QA

            People

            • Assignee:
              Unassigned
              Reporter:
              Joao Pingo (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 2 days, 1 hour, 30 minutes
                2d 1h 30m