Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-19893

Image Objects are not correctly displayed in ezflow

    Details

      Description

      Image objects are not displayed when trying to access them through the front-end (i.e: ezflow), and showing unexpected behavior when caches are cleared.

      Scenario 1:

      • Create a folder, and within it an Image object in the admin interface
      • Verify that you can view it by accessing the image, still in the admin interface
      • Go to the front-end, i.e, ezflow
      • Access the folder wherein you created the Image, verify that you can see its thumbnail
      • Access the Image, verify that you cannot see the image

      Scenario 2:

      • Create the folder and Image object as you did in the previous scenario
      • In the front-end, access the folder wherein you created the Image
      • Through the terminal, clear all caches
      • Refresh the page, the thumbnails will now be gone *

      * The image is visible again only if, through the admin interface, you edit the Image object, and then discard the draft

      There are zero errors or notices (apache logs, symfony logs/debugger (using index_dev), ezpublish-legacy logs, Firebug & Chrome dev-tools); everything works as expected by bypassing symfony and accessing the ezpublish_legacy directory directly.

        Activity

          People

          • Assignee:
            Unassigned
            Reporter:
            Filipe Dobreira (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 1 hour
              1h