Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-19849

eZPublish 5 pgsql database type does not map to a valid eZPublish legacy handler

    XMLWordPrintable

    Details

      Description

      The ezp5 configurations in app/config now take precedence over (some?) legacy settings. This causes an issue with PostgreSQL handling (and possibly other handlers/engines) when a valid database type in ezp5 does not correctly map to a known/valid database handler in ezp legacy.

      Example:

      ezp5 knows the following database types: mysql, sqlite, pgsql
      ezp legacy knows the following database handlers: mysql, mysqli, postgresql, ezpostgresql, etc...

      Solution for pgsql:

      $ settings/site.ini

      [DatabaseSettings]
      ImplementationAlias[pgsql]=eZPostgreSQLDB
      

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            Filipe.Dobreira-obsolete@ez.no Filipe Dobreira (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 6 hours, 15 seconds
                6h