Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-19835

REST interface doesn't recognize SSL properly

    Details

      Description

      The processEncryption() function, located under kernel/private/rest/classes/request/http_parser.php, is not recognizing SSL properly. The following line

      if ( !empty( $_SERVER['HTTPS'] ) )
      

      ...should be changed to:

      if ( eZSys::isSSLNow() )
      

        Activity

        Hide
        Bertrand Dunogier added a comment -

        We should be fine with this. However, note that I am not able to reproduce the issue with my setup (apache2): the RequireHTTPS option does work as expected.

        I'll have to go for the suggested fix, which I can at least test.

        Show
        Bertrand Dunogier added a comment - We should be fine with this. However, note that I am not able to reproduce the issue with my setup (apache2): the RequireHTTPS option does work as expected. I'll have to go for the suggested fix, which I can at least test.
        Hide
        Bertrand Dunogier added a comment -
        Show
        Bertrand Dunogier added a comment - Fixed in master (eZ Publish 5.1): https://github.com/ezsystems/ezpublish/commit/05e3f58c

          People

          • Assignee:
            Unassigned
            Reporter:
            Nuno Oliveira (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 1 day, 3 hours, 15 minutes
              1d 3h 15m