Details

      Description

      embed-inline (Inline checkbox ticked, not just drop-down selected) needs same treatment as embed.

      Problem found:
      1. Trying to enter a row under an embed-inline object is impossible unless a paragraph already exists beneath or between two embed-inline objects.

      2. Keyboard (arrows) navigation is not possible with embed-inline although it is with embed.

      3. Trying to embed object when embed-inline is ticked is not possible, clicking "Ok" results in the following error: el is null http://mysite.com/ezoe/relations/2853/67/auto/eZObject_2846 Line 88

      Relationship to:
      http://issues.ez.no/IssueView.php?Id=18209
      http://issues.ez.no/IssueView.php?Id=18419

      This is an ongoing issue that is frustrating clients a source of disappointment, please address this.

      Steps to reproduce

      Click embed button, browse to object and tick "Inline" checkbox.

        Issue Links

          Activity

          Hide
          Gunnstein Lye added a comment -

          Closing since this is has been released. Further fixes will be done in EZP-23981.

          Show
          Gunnstein Lye added a comment - Closing since this is has been released. Further fixes will be done in EZP-23981 .
          Hide
          André Rømcke added a comment -

          Guys, remember to open new issue and not reopen when a issue is already part of a release, which is the case here

          Show
          André Rømcke added a comment - Guys, remember to open new issue and not reopen when a issue is already part of a release, which is the case here
          Hide
          Rui Silva (Inactive) added a comment -

          @Brendan Pike, thank you for shedding light on this.
          I had seen this happen, but since the keyboard navigation only seems to get stuck at the element itself and not everywhere in the XML field, I wasn't sure that was what you meant.

          Show
          Rui Silva (Inactive) added a comment - @Brendan Pike, thank you for shedding light on this. I had seen this happen, but since the keyboard navigation only seems to get stuck at the element itself and not everywhere in the XML field, I wasn't sure that was what you meant.
          Hide
          Brendan Pike added a comment -

          Its

          @Rui Silva,

          Its been awhile now, but I think I'm referring to not been able to mouse the selector around the content with normal keyboard navigation when an embed-inline object is involved. So for example if you place an embed-inline object in the middle of a sentence you will not be able to use the left arrow to move to the start of the sentence. Similarly if there is an embed-inline object at the top / left (first item) in an XML field I don't think its possible to write a row above it. From memory I had to first disable the editor place a new line above the inline object and then re-enable the editor. This is obviously not a what a clients would expect to have to do.

          Thanks again

          Show
          Brendan Pike added a comment - Its @Rui Silva, Its been awhile now, but I think I'm referring to not been able to mouse the selector around the content with normal keyboard navigation when an embed-inline object is involved. So for example if you place an embed-inline object in the middle of a sentence you will not be able to use the left arrow to move to the start of the sentence. Similarly if there is an embed-inline object at the top / left (first item) in an XML field I don't think its possible to write a row above it. From memory I had to first disable the editor place a new line above the inline object and then re-enable the editor. This is obviously not a what a clients would expect to have to do. Thanks again
          Hide
          Rui Silva (Inactive) added a comment -

          @Brendan Pike,
          regarding the problems found:

          2. Keyboard (arrows) navigation is not possible with embed-inline although it is with embed.

          Can you explain this one a little more detailed?
          I'm not sure what you mean with this one..

          Show
          Rui Silva (Inactive) added a comment - @Brendan Pike, regarding the problems found: 2. Keyboard (arrows) navigation is not possible with embed-inline although it is with embed. Can you explain this one a little more detailed? I'm not sure what you mean with this one..
          Hide
          Brendan Pike added a comment -

          Thank you guys!

          Show
          Brendan Pike added a comment - Thank you guys!
          Hide
          Gunnstein Lye added a comment -

          Reopen for QA

          Show
          Gunnstein Lye added a comment - Reopen for QA
          Hide
          André Rømcke added a comment - - edited

          Fixed in:
          https://github.com/ezsystems/ezpublish-legacy/commit/e1589dc13c2501f6f2de62fc3fbb2514f3ba9d77

          Fixes done in #EZP-20676 is also needed for full fix.
          Note: Could not reproduce arrow issue!

          Show
          André Rømcke added a comment - - edited Fixed in: https://github.com/ezsystems/ezpublish-legacy/commit/e1589dc13c2501f6f2de62fc3fbb2514f3ba9d77 Fixes done in # EZP-20676 is also needed for full fix. Note: Could not reproduce arrow issue!

            People

            • Assignee:
              Unassigned
              Reporter:
              Brendan Pike
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 2 hours
                2h