Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-19103

Switching between siteaccess in "Design" -> "Templates" does not work correctly

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Low
    • Resolution: Unresolved
    • Affects Version/s: 4.0.7, 4.4.1, 4.5.0, 4.6.0
    • Fix Version/s: Customer request, Future
    • Component/s: Misc
    • Labels:
      None

      Description

      The template management does not show up the correct templates and throws errors if one switches between siteaccesses.

      The problem is as follows:

      One has a settings extension in which the settings for the different siteaccesses are configured. Especially those for the design. Example:

      extension/ezsettings/settings/siteaccess/ezwebin_site/site.ini.append.php
      extension/ezsettings/settings/siteaccess/ezwebin_admin/site.ini.append.php

      This means in settings/siteaccess/<SITE>/site.ini.append.php there are no design settings. If you try to make use of the template management functions, these will fail with e.g.

      Notice: Undefined index: template in /home/ablock/ez/websites/htdocs/ezp406/ezpublish-4.0.6/kernel/visual/templatelist.php on line 63

      and

      Error: eZTemplateDesignResource::overrideArray, tried files Aug 06 2009 13:45:17

      design/admin/override/templates/line/article_subpage.tpl, extension/ezdhtml/design/standard/override/templates/line/article_subpage.tpl, extension/ezodf/design/standard/override/templates/line/article_subpage.tpl, design/standard/override/templates/line/article_subpage.tpl

        Attachments

          Activity

            People

            • Assignee:
              unknown unknown
              Reporter:
              jh.ez.no Jarosław-- Heba
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: