Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-18818

(tc-45) - (eZ Flow) Geo map on eZ Flow doesn't work with oracle

    Details

      Description

      hi,
      The geo map doesn't work in oracle.
      We can create a geoarticle with no problem (when we click an address and click on "find adress", the address is correcly displayed).
      But when we verify the address in frontpage of eZ Flow, after adding a "Google Map Items", the map is in a differently position.

      in my var/log/error.log, i have the following information:
      [ Oct 24 2011 09:54:10 ] [192.168.2.2] eZTemplate:ezini:
      !!!No such variable 'CustomAttributeTypes' in group 'DemoBlock' for block.ini

      Similar behaviour as in http://issues.ez.no/17683.

      Steps to reproduce

      Create some google map objects
      	Log in as admin in ezflow
      	Create new folder "Conference"
      	Click on "Conference" in top menu
      	Create new folder "News"
      	Click in "News" in top sub menu
      	Create new Geo Article
      	Enter formdata:
      		Title : GeoArticle1
      		Summary: Summary of geo article1
      		Find address : Klostergata 33 skien Norway
      	Validate that Skien is located in the displayed map
      	Click "Update values" button
      	Click "Send for publishing"
      	Create new Geo Article
      	Enter formdata:
      		Title : GeoArticle2
      		Summary: Summary of geo article2
      		Find address : Porsgrunn Norway
      	Validate that Porsgrunn is located in the displayed map
      	Click "Update values" button
      	Click "Send for publishing"
      	Click on "Conference" in top menu ( Yes, the last article will be made below /Conference (not /Conference/News) )
      	Create new Geo Article
      	Enter formdata:
      		Title : GeoArticle3
      		Summary: Summary of geo article3
      		Find address : Bamble Norway
      	Validate that Bamble is located in the displayed map
      	Click "Update values" button
      	Click "Send for publishing"
       
      Create the dynamic google map block
      	Go to frontpage
      	Edit frontpage
      	Add block "Google Map Items"
      	Move the block to the top using drag&drop
      	Edit googlemap block:
      		Add Conference/ as source
      		class : geo_article
      		attribute : location
      		limit : 33
      		width : 
      		height :
      	Publish frontapge
      	Visit frontpage and ensure All three geo articles are display
      
      

        Issue Links

          Activity

          Hide
          Paulo Cardiga added a comment -

          Hi,
          Currently, in ezp5, it's not working again.
          Following the steps described above, i have a map without the coordenated specified.

          On source page, i have the following:

          <script src="http://maps.google.com/maps?file=api&amp;v=2&amp;key=ABQIAAAANL-L8Kua_1OrtByxNfjG5xRIDnndiEdswQ1y0foGhbQf-e0fjRSH0KnzXgG6UNWQoiiJUXOTO1yNBA" type="text/javascript"></script>
           
           
          <script type="text/javascript">
              var data731e790abf715d52455bde10e1f8931e = [];
              
              
              eZFLGMapAddListener( window, 'load', function(){ eZFLGMapView( '731e790abf715d52455bde10e1f8931e', data731e790abf715d52455bde10e1f8931e ) }, false );
          </script>
          

          so it seems that the geopoints are not being generated.

          Show
          Paulo Cardiga added a comment - Hi, Currently, in ezp5, it's not working again. Following the steps described above, i have a map without the coordenated specified. On source page, i have the following: <script src="http://maps.google.com/maps?file=api&amp;v=2&amp;key=ABQIAAAANL-L8Kua_1OrtByxNfjG5xRIDnndiEdswQ1y0foGhbQf-e0fjRSH0KnzXgG6UNWQoiiJUXOTO1yNBA" type="text/javascript"></script>     <script type="text/javascript"> var data731e790abf715d52455bde10e1f8931e = []; eZFLGMapAddListener( window, 'load', function(){ eZFLGMapView( '731e790abf715d52455bde10e1f8931e', data731e790abf715d52455bde10e1f8931e ) }, false ); </script> so it seems that the geopoints are not being generated.
          Hide
          André Rømcke added a comment -

          Moving issue back to Backlog as it is not actively in development.

          Show
          André Rømcke added a comment - Moving issue back to Backlog as it is not actively in development.
          Hide
          Damien Pobel (Inactive) added a comment -

          @Paulo I'm not able to reproduce this issue. It's working as expected for me. It's seems like the fetch(content, tree) in extension/ezflow/design/ezflow/override/templates/block/geo_located_content.tpl around line 22 does not return anything. Could you double check the parameters you set for the block and check that they are available in the template for instance by adding right before the fetch the following lines:

          {debug-log var=$block.custom_attributes.parent_node_id msg='Parent node id (Conference?)'}
          {debug-log var=$block.custom_attributes.class msg='Class (geo_article?)'}
          {debug-log var=$limit msg='Limit (33 ?)'}

          Show
          Damien Pobel (Inactive) added a comment - @Paulo I'm not able to reproduce this issue. It's working as expected for me. It's seems like the fetch(content, tree) in extension/ezflow/design/ezflow/override/templates/block/geo_located_content.tpl around line 22 does not return anything. Could you double check the parameters you set for the block and check that they are available in the template for instance by adding right before the fetch the following lines: {debug-log var=$block.custom_attributes.parent_node_id msg='Parent node id (Conference?)'} {debug-log var=$block.custom_attributes.class msg='Class (geo_article?)'} {debug-log var=$limit msg='Limit (33 ?)'}
          Hide
          Paulo Nunes (Inactive) added a comment -

          @Damien
          In the current build, using Oracle on Legacy (https://confluence.ez.no/pages/viewpage.action?pageId=2720338), this error no longer occur.
          (the issue was opened when testing ezp with oracle under simfony, what is not currently the case.)

          Show
          Paulo Nunes (Inactive) added a comment - @Damien In the current build, using Oracle on Legacy ( https://confluence.ez.no/pages/viewpage.action?pageId=2720338 ), this error no longer occur. (the issue was opened when testing ezp with oracle under simfony, what is not currently the case.)
          Hide
          Paulo Nunes (Inactive) added a comment -

          In the current conditions, using Oracle on LS (https://confluence.ez.no/pages/viewpage.action?pageId=2720338), the error no longer occur.

          Show
          Paulo Nunes (Inactive) added a comment - In the current conditions, using Oracle on LS ( https://confluence.ez.no/pages/viewpage.action?pageId=2720338 ), the error no longer occur.

            People

            • Assignee:
              Unassigned
              Reporter:
              Paulo Cardiga
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 7 hours
                7h