Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-18737

Regression in eZXMLInputParser::parseAttributes with attr='0'

    Details

      Description

      Regression from issue: http://issues.ez.no/18186 is causing attributes with a value of '0' to be removed from the resulting generated raw ezxml.

      Issue surfaced in ezoe issue: http://issues.ez.no/IssueView.php?Id=18657&activeItem=1
      Where border='0' was no longer stored in db, causing it to end up as border='' in ezoe output used by TinyMCE and most browser that ended up as border='1'..

      Steps to reproduce

      You need to use ezoe without this commit: https://github.com/ezsystems/ezoe/commit/1549eef79d954b879be71db2e409bcbe3b82e048
      As in it's parent or earlier.
       
       
      Create Content
       
       1. Login into admin2 interface, using admin account
       2. Click on “Content structure” from the top menu
       3. Click on “Create new”
       4. Choose “Article” from the drop-down list
       5. Title: Article 1
       6. In the summary field
       7. Click on “Insert a new table”
           Columns: 2
           Rows: 2
           Border: 0 px
           Summary (WAI): Table
       8. Click “ok” button
       9. On the fist Row, First column, type: Something
       10. On the second Row, Second column, type: Else
       11. Click on “Store draft” button
       12. Verify that the table, in Summary field, remains with no border
            + On this stage you can check value in database, where you will find that it is missing border attribute, while it should have been border='0'.
      

        Activity

        Hide
        Pedro Resende added a comment -

        Please see Test cases 534 and 666.

        Show
        Pedro Resende added a comment - Please see Test cases 534 and 666.
        Hide
        André R added a comment - - edited

        Cannot reproduce (border is dotted before and after clicking Store Draft), might be that it was fixed by fix in "#018738: Table is invisible if defined with border 0%".

        Show
        André R added a comment - - edited Cannot reproduce (border is dotted before and after clicking Store Draft), might be that it was fixed by fix in "#018738: Table is invisible if defined with border 0%".
        Hide
        Geir Arne Waaler added a comment -

        The issue is fixed. I move it to Closed.

        Geir Arne Waaler
        eZ Documentation

        Show
        Geir Arne Waaler added a comment - The issue is fixed. I move it to Closed. Geir Arne Waaler eZ Documentation
        Hide
        André R added a comment - - edited

        Reopen, this is affecting other browsers then Chrome for some reason. It is same issue as http://issues.ez.no/018657 in oe tracker.

        Show
        André R added a comment - - edited Reopen, this is affecting other browsers then Chrome for some reason. It is same issue as http://issues.ez.no/018657 in oe tracker.
        Hide
        André R added a comment -

        The ezoe issue that this issue is triggering is fixed in ezoe: http://issues.ez.no/IssueView.php?Id=18657&

        But the regression remains.

        Show
        André R added a comment - The ezoe issue that this issue is triggering is fixed in ezoe: http://issues.ez.no/IssueView.php?Id=18657& But the regression remains.
        Show
        André R added a comment - Fixed in: https://github.com/ezsystems/ezpublish/commit/242717ae563fd97c1aba8643ff5644422818816e
        Hide
        Geir Arne Waaler added a comment -

        I try again! The issue is fixed. I move it to Closed.

        Show
        Geir Arne Waaler added a comment - I try again! The issue is fixed. I move it to Closed.

          People

          • Assignee:
            André R
            Reporter:
            Pedro Resende
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: