Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-18696

Object not available when creating a new class with eZPublish 4.1.1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: QA tracked issues
    • Labels:
      None
    • Environment:

      Operating System: Debian 5
      PHP Version: 5.2.17
      Database and version: MySQL 5.2.51a-24+lenny4
      Browser (and version):

      Description

      After creating a new class with eZPublish 4.1.1, when creating a object of that class it remains unavailable

      Steps to reproduce

      Create a new class
       
      1. Login into admin interface, using admin account
      2. Click on Setup, from the top menu
      3. Click on Classes, from the left menu
      4. Click on Content link
      5. Click on New class button
      6. Type the following text in the fields
       
      Name: A new class
      Identifier: a_new_class
      Object name pattern: <name>
      URL alias name pattern: 
      Container: unchecked
      Default sorting of children: Path String/Ascending
      Default object availability: unchecked
       
      7. Chose Text line from the drop-down list of the attribute
      8. Click on Add attribute button
      9. Type the following text in the fields
       
      Name: Name
      Identifier: name
      Required: unchecked
      Searchable: checked
      Information collector: unchecked
      Disable translation: unchecked
      Default value:
      Max string length: 0 characters
       
      10. Chose image from the drop-down list of the attribute
      11. Click on Add attribute button
      12. Type the following text in the fields
       
      Name: Image
      Identifier: image
      Required: unchecked
      Searchable: unchecked
      Information collector: unchecked
      Disable translation: unchecked
      Max file size: 0 MB
       
      13. Click OK Button
       
      Creating a new Folder
       
      1. Click on Content structure from the top menu
      2. Chose Folder from the drop-down list
      3. Click on Create new button
      4. Type the following text in the fields
       
      Name: News
       
      5. Click on Send for publishing button
       
      Creating a new Object
       
      1. Click on Content structure from the top menu
      2. Click on News link
      3. Chose A new class from the drop down
      4. Click on Create new button
      5. Type the following text in the fields
       
      Name: A new Image
      New image file for upload: <Chose an image from you HD>
      Alternative image text: This is a test
       
      6. Click on Send for publishing button
      7. Verify that you can see the Name of the Object
      
      

      1. Capture.PNG
        21 kB
      2. Capture1.PNG
        12 kB

        Activity

        Pedro Resende added a comment -

        !Capture.PNG|thumbnail! View after creating class

        Pedro Resende added a comment -

        !Capture1.PNG|thumbnail! After left click on the object

        Damien Pobel (eZ) added a comment -

        First: did you really execute this test in the end of september in eZ Publish 4.1.1? (current version is 4.5 and 4.6 will be released in 2 weeks!)

        Second: not able to reproduce this issue in master nor 4.6.


          People

          • Assignee:
            unknown
            Reporter:
            Pedro Resende
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: