Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-18668

Sub-Items “Table Options” Custom Settings not working properly

    Details

      Description

      After defining a custom visible table columns, apparently there is a issue loading does definition when login in the admin interface with another user.

      Steps to reproduce

      Create a new user
       
      1. Login as “admin” in eZPublish admin 2 interface
      2. Click “User Accounts” in top menu.
      3. Inside the “Sub-Items”, press “Administrator Users”.
      4. Create new “User”:
      First name (required) : Story
      Last name (required) : 13570
      Username: S13570
      Password: qwerty
      Email: S13570@example.com
       
      5. Press “Send for Publishing” button on the bottom of the page.
       
      Customize Interface for Admin
       
      1. Login as “admin” in eZPublish admin 2 interface
      2. Click “Content Structure” in top menu.
      3. Press “Table Options” inside the “Sub-Items” menu, on the bottom of the page.
      4. Select only the following Visible table columns:
      Name
       Visibility
       Type
       Modified
       Node ID
       Object ID
       
      5. Close the “Table Options” menu, and confirm that the changes were made.
      6. Press “Media Library” on the top menu.
      7. Press “Table Options” inside the “Sub-Items” menu, on the bottom of the page.
      8. Select only the following Visible table columns:
      Node Remote ID
       Object Remote ID
       
      9. Close the “Table Options” menu, and confirm that the changes were made.
      10. Press “User Accounts” on the top menu.
      11. Press “Table Options” inside the “Sub-Items” menu, on the bottom of the page.
      12. Select only the following Visible table columns:
      Section
       Priority
       
      13. Close the “Table Options” menu, and confirm that the changes were made.
      14. Logout as “admin”, minimize the browser and open ANOTHER browser (not the same)
       
      Customize Interface for S13570
       
      1. Login as “S13570:qwerty” in eZPublish admin 2 interface
      2. Click “Content Structure” on the top menu.
      3. Confirm that the Sub-items have only  the following 4 default columns for un-customized users:
      Name
       Visibility
       Published
       Priority
      
      

        Issue Links

          Activity

          Hide
          Paulo Cardiga added a comment -

          Worked after clearing all caches

          Show
          Paulo Cardiga added a comment - Worked after clearing all caches
          Hide
          Paulo Cardiga added a comment -

          The problem is still occurring on 4.7.0-dev

          Show
          Paulo Cardiga added a comment - The problem is still occurring on 4.7.0-dev
          Show
          Vidar Langseid added a comment - Seem to have been fixed after the following commits by AR https://github.com/ezsystems/ezie/commit/bd687bf0d16bf900687d01bcfa3982728a1fb35c https://github.com/ezsystems/ezjscore/commit/7cc863831984ed55d2b469b90f6d96cb8e97af2c
          Hide
          Pedro Resende added a comment -

          This issue was found when running the test case tc-405:Test the Sub-Items “Table Options” Custom Settings

          Show
          Pedro Resende added a comment - This issue was found when running the test case tc-405:Test the Sub-Items “Table Options” Custom Settings

            People

            • Assignee:
              Paulo Cardiga
              Reporter:
              Pedro Resende
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: