Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-18296

(tc-501) - After approval, the system does not send an email informing that an account is activated.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Obsolete
    • Affects Version/s: None
    • Fix Version/s: QA tracked issues
    • Labels:
      None
    • Environment:

      Operating System:
      PHP Version: (please be specific, like '4.4.3' or '5.1.5')
      Database and version: mysql 5.5
      Browser (and version): Firefox 3.6

      Description

      When an administrator approves a new user registration, the system does not send an email informing that the account is activated.

      Version 4.5.0

      Steps to reproduce

      Create Workflows
       
         1. Login as admin in admin2 interface
         2. Press "User Accounts" on the top menu
         3. Click "Administrator Users" group, and edit the "Administrator" user.
         4. Change the admin e-mail to one that you have access to. (You will need this to receive notifications)
            E-mail: (e-mail you have access to)
         5. Send por publishing.
         6. Click “Setup” on the top menu
         7. Press “Workflows” on the left side.
         8. Click “Standard” link
         9. Click “New Workflow” button on the bottom of the page
        10. Under “Groups who approve content” press “Add Groups” button.
        11. Select the “Editors” and the “Administrators” checkbox, and press “Select” button on the bottom.
        12. Insert the following data:
            Name: Before Workflow
            Description / comments: Before Workflow
            Affected sections: Users
            Affected versions: Publishing new object
        13. Click “Add Event” button
        14. Press “OK” on the bottom of the page
        15. Press “Add Workflow” button on the bottom of the page again
        16. Insert the following data:
            Name: After Workflow
        17. On the Drop-down box, choose “Event / Finish User Registration”
        18. Insert the following data:
            Description / comments: After Workflow
        19. Press “OK” on the bottom of the page.
       
       
       
      Activate Workflows
       
         1. Login as admin in admin2 interface
         2. Click “Setup” link in top menu
         3. Press “Triggers” in the left side menu
         4. Under “Content - Publish - Before” on the Drop-down box, choose “Before Workflow”
         5. Confirm that there was only that possibility on the Drop-down box.
         6. Under “Content - Publish - After” on the Drop-down box, choose “After Workflow"
         7. Confirm that there was only that possibility on the Drop-down box.
         8. Press “Apply Changes” button on the bottom of the page
         9. Open your shell command line, and type:
            $ rm -rf /tmp/sess_*
            This command deletes all the sessions handlers in order to bypass the testsystem session handler.
       
       
       
      Register User
       
         1. Open admin2 in browser.
         2. Press “Register” button
         3. Input data:
            First Name: John
            Last Name: Doe
            Username: John
            Password: testuser
            Confirm Password: testuser
            E-mail: (ANOTHER email_that_you_have_access)
         4. Press “ok” button at the end of the page.
         5. Confirm you get the message:
            “Your account was successfully created. An email will be sent to the specified email address. Follow the instructions in that mail to activate your account.”
         6. Press “ok” button
       
       
       
      Activate account
       
         1. Access your e-mail, and confirm you receive an e-mail indicating your registration on the system.
         2. Press the URL to confirm your account.
         3. Confirm you get a massage like:
            “Your email address has been confirmed. An administrator needs to approve your sign up request, before your login becomes valid.”
       
       
       
      Approve or reject user object
       
         1. Login as admin in admin2 interface
         2. Confirm that you have a pending request on the dashboard page.
         3. Click “Collaboration” on the left site menu.
         4. Confirm that you have a pending request on the Item List
         5. Click John Doe awaits your approval link.
         6. Press “Approve” button
         7. Confirm that you get a message indicating “No new items to be handled.”
       
       
       
      Run Crontab
       
         1. Click “Selenium Tests” tab on the top menu
         2. Click “CronJobs” on the left menu
         3. Choose “Plain_site_admin” on the siteaccess Drop-down box.
         4. Click “Execute cron now” button on the “Frequent” crontab.
         5. Confirm that the message contains:
            Workflow done(2): 1
            1 out of 1 processes was finished
         6. Click “Dashboard” on the top menu, and confirm that currently you do not have any pending items available.
       
       
       
      Confirm User Group
       
         1. Click “User Accounts” on the top menu
         2. Click “Guest Accounts” on the left site menu
         3. Confirm that you have a “John Doe” user.
       
       
       
      Confirm User Access
       
         1. Open e-mail client and confirm you have received an e-mail notification indicating that the registration was approved.
         2. The E-mail must have the subject “User registration approved” and the content:
                Thank you for registering at [host URL]
                Your registration has been approved. You can login with your account John Doe.
                Click the following URL to login:
                http://[host URL]/user/login
         3. Login as John Doe in admin2 interface.
            Username: John
            Password: testuser
         4. Confirm that you were able to login, but got an error message indicating that the current page cannot be displayed (permissions problems, the user has “GUEST” privileges)
         5. Logout.
         6. Login as John Doe in plain_site
            Username: John
            Password: testuser
         7. Confirm that you were able to login.
      
      

        Activity

        ezrobot added a comment -

        This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


          People

          • Assignee:
            unknown
            Reporter:
            Disabled User
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: