Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-18270

eZFlow: "Push to block" view not working correctly when AllowedClasses settings is used

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Duplicate
    • Affects Version/s: 4.4.0, extension/ezflow 2.2
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Operating System: Debian
      PHP Version: (please be specific, like '4.4.3' or '5.1.5'): 5.3.2
      Database and version:
      Browser (and version):

      Description

      There seems to be a bug in administration interface when using "Push to block" module view, and AllowedClasses setting is defined for a block in block.ini.

      One of post parameters being sent in AJAX call when specific zone in second drop down ("Select zone") is selected is "node_id", which is mapped to previously selected frontpage node id.

      But then in modules/ezflow/get.php , in line 83 class identifier of this node is expected to be in the AllowedClasses array. This seems wrong, as objects being pushed to block should be evaluated to be of filtered class, not the frontpage object itself.

      Steps to reproduce

      Define AllowedClasses settings to a manual block in block.ini.

      Try to use "Push to block" feature (on a object of a class defined in AllowedClasses settings) in administration interface. This should fail.

        Issue Links

          Activity

          Disabled User added a comment -

          tc-535 was created for this issue

          Geir Arne Waaler added a comment -

          I move this from Code Review to Closed because it is handled in another issue.

          Geir Arne Waaler
          eZ Documentation

          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


            People

            • Assignee:
              Gaetano Giunta
              Reporter:
              Igor Vrdoljak
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: