Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-18264

ezOE not possible to embed internal objects with two tables after eachother.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Fixed
    • Affects Version/s: 4.4.0
    • Fix Version/s: None
    • Component/s: Misc
    • Labels:
      None
    • Environment:

      ez 4.4
      ezoe 5.2

      Description

      When inserting internal links in two or more tables right after each others without spaces the internal link disappears when "send for publishing", "store draft" or "disable editor".

      Steps to reproduce

      1) Create two or more tables after each other (with no space).
      2) Insert object (internal link).
      3) Try "disable editor", "send for publishing" or "store draft".
      4) Internal link is gone.

        Issue Links

          Activity

          Hide
          Disabled User added a comment -

          tc-534 was created for this issue

          Show
          Disabled User added a comment - tc-534 was created for this issue
          Show
          Damien Pobel (eZ) added a comment - Fixed in : ezoe master https://github.com/ezsystems/ezoe/commit/2707c7e ezoe stable 5.3 https://github.com/ezsystems/ezoe/commit/343ce16 ezoe stable 5.2 https://github.com/ezsystems/ezoe/commit/7f884bd
          Hide
          Damien Pobel (eZ) added a comment -

          Reopening since the same occurs when saving the draft twice.

          Show
          Damien Pobel (eZ) added a comment - Reopening since the same occurs when saving the draft twice.
          Show
          Damien Pobel (eZ) added a comment - Fixed in : ezoe master https://github.com/ezsystems/ezoe/commit/15ca1effb373c981333f44c80ab3ae78cab21966 ezoe stable-5.3 https://github.com/ezsystems/ezoe/commit/d05be4b67604c680162cca01560a3a0f93349ed5 ezoe stable-5.2 https://github.com/ezsystems/ezoe/commit/cae6a220f4802b7396fccc59117ab636fb6e5227
          Hide
          Laurent Dorier added a comment -

          I don't think that not the real fix for this issue, because you can reproduce the bug without using the ezoe popup feature.

          Just add a table with an embed object inside a cell.
          Copy/Paste this HTML table to add more tables with this object in ezoe (without adding extra lines between tables).
          Publish.
          Edit again (no modification required, just click on edit). Everything looks fine.

          Publish again => Cells with objects disappear.

          I hope it helps.

          Show
          Laurent Dorier added a comment - I don't think that not the real fix for this issue, because you can reproduce the bug without using the ezoe popup feature. Just add a table with an embed object inside a cell. Copy/Paste this HTML table to add more tables with this object in ezoe (without adding extra lines between tables). Publish. Edit again (no modification required, just click on edit). Everything looks fine. Publish again => Cells with objects disappear. I hope it helps.
          Hide
          Damien Pobel (eZ) added a comment -

          Reason of a regression in IE8, fixed in http://issues.ez.no/19390

          Show
          Damien Pobel (eZ) added a comment - Reason of a regression in IE8, fixed in http://issues.ez.no/19390

            People

            • Assignee:
              Damien Pobel (eZ)
              Reporter:
              Ruben Romão
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: