Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-18147

Postgres ezp4.4 to ezp4.5 upgrade generates database warnings

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.5.0beta2
    • Fix Version/s: QA tracked issues
    • Component/s: Database related
    • Labels:
      None

      Description

      Upgrading the 4.4 to 4.5 using Postgres Database is Showing warnings when running the dbupdate-4.5.0alpha1-to-4.5.0beta1.sql and when checking for Database Consistency in the Admin Interface.
      See the attache files

      Steps to reproduce

      In putty of to update/database/postgresql/4.5/unstable/
      Using the pqsql tool run the following update script's
      1.dbupdate-4.4.0-to-4.5.0alpha1.sql
      2.dbupdate-4.5.0alpha1-to-4.5.0beta1.sql
      3.dbupdate-4.5.0beta1-to-4.5.0beta2.sql
      

      Check the file upgrade_warnings_psql.txt for putty printscreen

      1.Enter the Admin Interface
      2. Open Setup->Upgrade check
      3. Press Database consistency check
      

      Check the file uSystem Upgrade - eZ Flow .png for site printscreen

        Issue Links

          Activity

          Chen Xiongjie added a comment -

          The problem is because eZPgsqlSchema::schema return wrong field definition based on .dba (ref code in kernel/setup/systemupgrade.php

           
              $differences = eZDbSchemaChecker::diff( $dbSchema->schema( array( 'format' => 'local', 'force_autoincrement_rebuild' => true ) ), $originalSchema );
          
          

          )

          Patrick Allaert added a comment -

          The notice displayed are normal, they are simple notice that can be safely ignored.
          Setting PostgreSQL's variable "log_min_messages" to "error" is a known way to avoid that notice to be reported (but doesn't work here).

          The errors from db upgrade check should all be fixed from the related issue.

          Geir Arne Waaler added a comment -

          Issue fixed from related issue. I move it to Closed.


            People

            • Assignee:
              Patrick Allaert
              Reporter:
              João Pingo
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: