Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-17974

Unable to modify/remove workflow if workflow extension is deactivated

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Fixed
    • Affects Version/s: 4.0.7, 4.1.4, 4.2.0, 4.3.0, 4.4.0, 4.5.0alpha
    • Fix Version/s: 4.5.0beta1
    • Component/s: Legacy/Workflows
    • Labels:
      None

      Description

      Steps to reproduce

      1. add extension with workflow
      2. registere and use workflow
      3. remove extension without unregistering workflow or purging objects using workflow.
      4. try to unregister/remove workflow - ez publish fatals with message error:

      Fatal error: Call to a member function validateHTTPInput() on a non-object in /var/www/ezpublish/kernel/workflow/edit.php on line 206
      Fatal error: eZ Publish did not finish its request
       
      The execution of eZ Publish was abruptly ended, the debug output is present below.
      

        Issue Links

          Activity

          Geir Arne Waaler added a comment -

          No documentation needed.

          Geir Arne Waaler
          eZ Documentation

          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


            People

            • Assignee:
              Jérôme Vieilledent
              Reporter:
              Jarosław-- Heba
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: