Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 4.5.0alpha
    • Fix Version/s: 4.5.0
    • Component/s: Caching
    • Labels:
      None

      Description

      Accessing a page on a siteaccess configured with a language having no translations (no share/translations/<language>) will reset the expiry timestamp (key "ts-translation-cache" in var/ezwebin_site/cache/expiry.php) on every request.
      This happens with:
      eng-US
      fre-BE
      por-PT
      ukr-UA
      kor-KR
      ...

        Issue Links

          Activity

          André R added a comment -

          Can confirm on a nor-NO siteaccess, but in my case I do have a translation for it.

          Patrick Allaert added a comment -

          In reply to comment #053368
          Do you mean the expiry is reset on every request while you do have share/translations/nor-NO/translation.ts? In such a case, this might be a different, but related, issue.

          André R added a comment -

          In reply to comment #053369
          It was different, it was a regression on #017278.

          Patrick Allaert added a comment -

          Note that while fixing this, it should be tested with several combinations of:
          a) i18n.ini/[TranslationSettings]/FallbackLanguages[xxx-YY]=xxx-ZZ active and not.
          b) eng-US + another one, knowing that eng-US with a fallback on eng-GB will not use a translation.ts file and this is what happen with an installation using all default values from the setup.

          Jérôme Vieilledent added a comment -

          This is actually due to lack of fallback languages in i18.ini

          Geir Arne Waaler added a comment -

          Reported as fixed. Also related issue is fixed. I move it to Closed.

          Geir Arne Waaler
          eZ Documentation


            People

            • Assignee:
              Jérôme Vieilledent
              Reporter:
              Patrick Allaert
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: