Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-17765

ViewCache for related objects is not cleared

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.4.0, 4.5.0alpha
    • Fix Version/s: QA tracked issues
    • Component/s: Caching
    • Labels:
      None

      Description

      Seems like this bug has been re-introduced : #011628: View Cache for related objects is not properly cleared

      The bug is reproducable in 4.4.0 and 4.5.0alpha.
      It works in 4.3.0, but this version gives a PHP notice upon publishing object with a Relation Object attrelations attribute:

      Notice: PHP: E_NOTICE  	Dec 14 2010 11:35:22
      Undefined variable: classContent in /data1/www/apache2php52/ezp430/.run/kernel/classes/datatypes/ezobjectrelationlist/ezobjectrelationlisttype.php on line 78
      

      Steps to reproduce

      Make sure you have reverse_attribute setting in viewcache.ini

      [ViewCacheSettings]                                                                                                                                                                                         
      ClearRelationTypes[]=attribute                                                                                                                                                                              
      ClearRelationTypes[]=reverse_attribute
      

      and then follows "Steps to reproduce in #11628

        Issue Links

          Activity

          Vidar Langseid added a comment -

          FYI : works fine (without any notices) in 4.2

          Damien Pobel (eZ) added a comment -

          I'm not able to reproduce this issue with the current master branch from github nor with the stable-4.5 branch.

          Geir Arne Waaler added a comment -

          Evaluated as Cannot reproduce. I move it to Closed.


            People

            • Assignee:
              Damien Pobel (eZ)
              Reporter:
              Vidar Langseid
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: