Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-17241

tc-181 (Oracle) Translating a class in admin 2 interface generates a database error

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 4.4.0beta2, extension/ezoracle 1.8.2, extension/ezoracle 2.0.3
    • Fix Version/s: QA tracked issues
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Database : Oracle

      Description

      Adding the translation to class using the ORACLE test system, generates a database error, see the attached image to view the error.
      

      Steps to reproduce

      Setup - Add a new language
       
         1. Log in to Linux
         2.  type the following command:
            cd /var/www/apache2ph52/trunk
       
            vi .run/settings/siteaccess/plain_site_admin/site.ini.append.php
         3. At the bottom of the page, after the eng-ENG code, paste the following code:
            SiteLanguageList[]=por-PT
         4. Save and close vi
         5. Log into admin as admin
         6. Click on "Setup" tab on top menu
         7. Click on "Languages" link on the left side menu
         8. Click on "Add language" button
         9. On "Translation" combo box, choose portuguese (Portugal)
        10. Click "OK" button
       
       
      Create Class in English
       
         1. Select "Setup" tab on top menu
         2. Select "Classes" link on left menu
         3. Select "Content" class group
         4. Scroll down and press "NewClass" button
         5. Fill in the following data
         6.       Name: Cl181
         7.       Identifier: Cl181
         8.       Decription: Cl181 English
         9. Click on "Add attributes" for attribute "Text line"
        10. Fill in the following data
        11. Name: Att181 En
        12. Identifier: Att181
        13. Description: Att181 English
       
      Confirm that exists a new category field
       
         1. Verify that exists a new category field
         2. Press "OK" button
       
      Add translatable description text per class and per Attribute for use as help text for editors (ie serialized_description_list)
       
         1. In the combo box before "Edit" button, select "Another language"
         2. Press "Edit" button
         3. Select language to add as Portuguese
         4. Press "Edit" button
         5. Fill in the following data
            Name: Cl181 Pt
            Decription: Cl181 Portugal
         6. Check that the "Identifier" field was filled in
         7. On Class attributes, fill in the following data:
       
            Name: Att181 Pt
       
            Description: Att181 Portugal
         8. Click "OK" button
         9. Click "Edit" button with combo box "English (United Kingdom)"
        10. Verify that Class name and Class description are in english
        11. Verify that Attribute name and Attribute description are in english
        12. Click "OK" button
        13. Click "Edit" button with combo box "Portuguese (Portugal)"
        14. Verify that Class name and Class description are in Portuguese
        15. Verify that Attribute name and Attribute description are in Portuguese
        16. Verify that the Class' labels and attribute's labels are also in portuguese
        17. Click "OK" button
      
      

        Activity

        Gaetano Giunta added a comment -

        Fixed in

        • stable/2.0.4 svn rev. 503
        • trunk/2.1 svn rev. 501, 502, 504
        Chen Xiongjie added a comment -

        @QA, remember to reinstall ezoracle to test it.

        Gaetano Giunta added a comment -

        fixed in stable/1.8.3 rev. 530

        Geir Arne Waaler added a comment -

        The issue is fixed. I move it to Closed.

        Geir Arne Waaler
        eZ Documentation


          People

          • Assignee:
            Chen Xiongjie
            Reporter:
            João Pingo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: