Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-16434

Style Editor, the "Elements">"h5" and "h6" have the same properties.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Fixed
    • Affects Version/s: 4.3.0beta2
    • Fix Version/s: QA tracked issues
    • Labels:
      None
    • Environment:

      Operating System: Linux5.2(please be specific, like '4.4.3' or '5.1.5')
      Database and version:
      Browser (and version): Firefox 3.6

      Description

      eZ Style Editor / Manual tests | tc-94:Test the items on the Elements menu (INCOMPLETE)
      

      In the Style Editor, the "Elements">"h5" and "h6" have the same properties. (cloned)
      If I change the values in H5 the H6 values are changed also. (with same values)
      

      Steps to reproduce

      Setup
       
         1. Log in as admin in ezwebin
         2. Click "News" in top menu
         3. Click "Test article" link
         4. Click "CSS" button in toolbar
       
      Test Link properties
       
         1. In the StyleEditors top menu, click Elements->Link
         2. Select Font -> color in drop down
         3. Click "Add" button
         4. Select some Yellow color in the color palette.
         5. Click "Apply" button
         6. Validate that the "link to ez.no" link turns yellow
         7. Click "Save" button
       
      Test Link: hover properties
       
         1. In the StyleEditor's top menu, click Elements->Link: hover
         2. Select Font -> color in drop down
         3. Click "Add" button
         4. Select some green color in the color palette.
         5. Click "Save" button
         6. Close the StyleEditor by clicking the "Exit" button in the StyleEditor's top menu
         7. Validate that the "link to ez.no" link turns green when you hover over it.
       
      Test H1 properties
       
         1. Click "CSS" button in toolbar
         2. In the StyleEditor's top menu, click Elements->H1
         3. Select Box -> margin-left in drop down
         4. Click "Add" button
         5. Enter "20" in input field
         6. Click "Save" button
         7. Validate that the "Test article" header is moved to the right
       
      Test H2 properties
       
         1. Click "CSS" button in toolbar
         2. In the StyleEditor's top menu, click Elements->H2
         3. Select Box -> margin-left in drop down
         4. Click "Add" button
         5. Enter "40" in input field
         6. Click "Save" button
         7. Validate that the "This is header 1" header is moved to the right
       
      Test H3 properties
       
         1. Click "CSS" button in toolbar
         2. In the StyleEditor's top menu, click Elements->H3
         3. Select Box -> margin-left in drop down
         4. Click "Add" button
         5. Enter "50" in input field
         6. Click "Save" button
         7. Validate that the "This is header 2" header is moved to the right
       
      Test H4 properties
       
         1. Click "CSS" button in toolbar
         2. In the StyleEditor's top menu, click Elements->H4
         3. Select Box -> margin-left in drop down
         4. Click "Add" button
         5. Enter "60" in input field
         6. Click "Save" button
         7. Validate that the "This is header 3" header is moved to the right
       
      Test H5 properties
       
         1. Click "CSS" button in toolbar
         2. In the StyleEditor's top menu, click Elements->H5
         3. Select Box -> margin-left in drop down
         4. Click "Add" button
         5. Enter "70" in input field
         6. Click "Save" button
         7. Validate that the "This is header 4" header is moved to the right
       
      Test H6 properties
       
         1. Click "CSS" button in toolbar
         2. In the StyleEditor's top menu, click Elements->H6
         3. Select Box -> margin-left in drop down
         4. Click "Add" button
         5. Enter "80" in input field
         6. Click "Save" button
         7. Validate that the "This is header 5" header is moved to the right
         8. Validate that also the "This is header 6" header is moved to the right
       
      Test User menu properties
       
         1. Click "CSS" button in toolbar
         2. In the StyleEditor's top menu, click Elements->Header->User menu
         3. Select Font -> font-family in drop down
         4. Click "Add" button
         5. Select "Times New Roman, Times, serif" in the drop down
         6. Click "Save" button
         7. Validate that font in the top header ("
         8. Validate that also the "This is header 6" header is moved to the right
      

        Activity

        Paulo Cardiga added a comment -

        Additional Note:
        In Oracle and Cluster mode platforms, changing "header 6" changes the "header 5" but NOT "Header 6"
        (tried with several properties)

        Vidar Langseid added a comment -

        AFAIK, selecting H1 in menu, actually makes a H2 in the document( H2 actually makes a H3 in the document and so on). This is because the Name of the object get H1...
        So since html doesn't have a H7, maybe simply the H6 menu choices should be removed ?

        Łukasz Serwatka added a comment -

        In reply to comment #051174
        Vidar's thinking confirms the implementation. I agree that we should remove H6 in order to be OK with ezxml output.

        Łukasz Serwatka added a comment -

        Fixed in ezstyleeditor

        trunk rev. 22
        stable/1.0 rev. 23

        Geir Arne Waaler added a comment -

        The issue is fixed. I move it to Closed.

        Geir Arne Waaler
        eZ Documentation


          People

          • Assignee:
            Łukasz Serwatka
            Reporter:
            Ricardo Goulart
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: