Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Fixed
    • Affects Version/s: 4.3.0alpha1
    • Fix Version/s: None
    • Component/s: Misc
    • Labels:
      None

      Description

      File: kernel/classes/ezcontentobjecttreenode.php
      Line: 5108
      Message: Call to undefined function ezi18n()
      Stacktrace:
      #0 eZContentObjectTreeNode::makeObjectsArray() called at [/home/patrick.allaert/Projets/ezpublish/kernel/classes/ezcontentobjecttreenode.php:5108]
      #1 eZContentObjectTreeNode::makeObjectsArray() called at [/home/patrick.allaert/Projets/ezpublish/kernel/classes/ezcontentobjecttreenode.php:3099]
      #2 eZContentObjectTreeNode::fetch() called at [/home/patrick.allaert/Projets/ezpublish/kernel/content/treemenu.php:148]
      #3 include(/home/patrick.allaert/Projets/ezpublish/kernel/content/treemenu.php) called at [/home/patrick.allaert/Projets/ezpublish/lib/ezutils/classes/ezprocess.php:66]
      #4 eZProcess->runFile() called at [/home/patrick.allaert/Projets/ezpublish/lib/ezutils/classes/ezprocess.php:41]
      #5 eZProcess::run() called at [/home/patrick.allaert/Projets/ezpublish/lib/ezutils/classes/ezmodule.php:1582]
      #6 eZModule->run() called at [/home/patrick.allaert/Projets/ezpublish/index_treemenu.php:172]

      A 'require_once' can be included at the top of kernel/classes/ezcontentobjecttreenode.php to solve this issue, however many files are using this function an don't require_once this file.

      In the current situation, the ezi18n() function is used from 261 different files while only 45 are including it.

      A better approach would be to have an eZi18n class to wrap this function so that the autoloader mechanism can do his job.

        Issue Links

          Activity

          Vidar Langseid added a comment -

          In what context do you experience this error? how to reproduce it?

          Patrick Allaert added a comment -

          No idea, can't see this error in the browser but it did happen. I can see it in APM who generated the provided stacktrace.

          André R added a comment - - edited

          Fixed in
          trunk (4.3.0beta1) rev. 24939 & 24940
          ezflow/trunk (2.1.0beta1) rev. 4431
          ezgmaplocation/trunk (2.1.0beta1) rev. 78 & 79

          Patrick Allaert added a comment -

          Fixed in:
          ezscriptmonitor (trunk): rev. 22

          André R added a comment -

          Class name does not follow new class name convention and should be renamed to ezpI18n.

          André R added a comment - - edited

          Fixed in
          trunk (4.3.0beta1) rev. 24987 & 25014
          ezflow/trunk (2.1.0beta1) rev. 4437 ( Changed so it uses function like all other extensions for now )
          ezoe/trunk (5.1.0beta1) rev. 173

          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


            People

            • Assignee:
              André R
              Reporter:
              Patrick Allaert
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: