Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-15932

StyleEditor: Removing styles doesn't update the editor's cache

    Details

      Description

      Hi

      If you add a attribute, and then removes it again, the attribute still seems to be there. I guess this is some cache bug inside the editor

      Steps to reproduce

      tc-87:Test setting background properties

      Setup
       
         1. Log in as admin in ezwebin
         2. View some article
         4. Click "CSS" button in toolbar
       
      Test background-color
       
         1. Click "Links" elements in the top right corner of the page ("Site settings" etc)
         2. Select "background-color" in drop down
         3. Click "Add" button
         4. Select some green color using the color palette
         5. Click "Apply" button
         6. Validate that background color changes to green
         7. Click "Save" button
         8. Validate that the font type remains
       
      Test removing background-color
       
         1. Click "Links" elements in the top right corner of the page ("Site settings" etc)
         2. Select the checkbox next to "Background-color"
         3. Click "Remove" button
         4. Click "Save" button
         5. Validate that the green background color is removed
      
      

      The last step will fail

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Ɓukasz Serwatka
            Reporter:
            Vidar Langseid
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: