Details

      Description

      With site main language ita-IT, when i try to add new translations for an image starting from the main language for those image (Italian) the entire folder in "/var/.../storage/images/<image_name>" for the italian translation is deleted.
      Obviously any documents that embed the image loss that in original language (Italian).

      Steps to reproduce

      1) Add new class image object in Italian and upload file
      2) Add new translation for that object starting from the main language (Italian)
      3) The original file in ita-IT version is missing!

        Issue Links

          Activity

          Hide
          Vidar Langseid added a comment -

          I am unable to reproduce this bug

          I install ezp420, ita-IT as main language, eng-GB as second language

          1. In admin, createing a image below /Media/Images (in ita-IT)
          2. Below /Getting-started/ I create a new article (in ita-IT) which embeds the image created above
          3. I translate the image in /Media/Images to eng-GB (do not upload new image, reusing the existing)
          4. No images are deleted from the system. The article in /Getting-started still shows correctly
          5. I edit the eng-GB translation of the image in /Media/Images to eng-GB : I upload new image, so that the ita-IT and eng-GB versions contains different images
          6. No images are deleted from the system. The article in /Getting-started still shows correctly
          Show
          Vidar Langseid added a comment - I am unable to reproduce this bug I install ezp420, ita-IT as main language, eng-GB as second language In admin, createing a image below /Media/Images (in ita-IT) Below /Getting-started/ I create a new article (in ita-IT) which embeds the image created above I translate the image in /Media/Images to eng-GB (do not upload new image, reusing the existing) No images are deleted from the system. The article in /Getting-started still shows correctly I edit the eng-GB translation of the image in /Media/Images to eng-GB : I upload new image, so that the ita-IT and eng-GB versions contains different images No images are deleted from the system. The article in /Getting-started still shows correctly
          Hide
          Francesco Bertoni added a comment -

          The bug seem to exist only if, when, at point 5 ("I edit the eng-GB translation of the image in /Media/Images to eng-GB : I upload new image, so that the ita-IT and eng-GB versions contains different images") select to translate the image in english and -started from the italian version- this is the difference. If i select to start with no translation the bug does not compare.

          Show
          Francesco Bertoni added a comment - The bug seem to exist only if, when, at point 5 ("I edit the eng-GB translation of the image in /Media/Images to eng-GB : I upload new image, so that the ita-IT and eng-GB versions contains different images") select to translate the image in english and - started from the italian version - this is the difference. If i select to start with no translation the bug does not compare.
          Hide
          (inactive) Gunnstein Lye added a comment -

          This duplicates #16078: Discarding translated draft removes original image
          (You were first to report it, but the other issue was fixed first.)
          http://issues.ez.no/16078

          Fixed in
          trunk (4.3.0beta2) rev. 25053 + 25065
          stable/4.2 (4.2.1) rev. 25054 + 25066
          stable/4.1 (4.1.5) rev. 25055 + 25067
          stable/4.0 (4.0.8) rev. 25056 + 25068

          Show
          (inactive) Gunnstein Lye added a comment - This duplicates #16078: Discarding translated draft removes original image (You were first to report it, but the other issue was fixed first.) http://issues.ez.no/16078 Fixed in trunk (4.3.0beta2) rev. 25053 + 25065 stable/4.2 (4.2.1) rev. 25054 + 25066 stable/4.1 (4.1.5) rev. 25055 + 25067 stable/4.0 (4.0.8) rev. 25056 + 25068
          Hide
          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.

          Show
          ezrobot added a comment - This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.

            People

            • Assignee:
              (inactive) Gunnstein Lye
              Reporter:
              Francesco Bertoni
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: