Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-15734

Transaction rollback on updating modified_subnode

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Fixed
    • Affects Version/s: 4.1.3
    • Fix Version/s: 4.5.0
    • Component/s: Database related
    • Labels:
      None

      Description

      On two different installations we have transaction rollbacks when publishing objects.

      [ Oct 29 2009 19:03:33 ] [192.168.1.100] eZMySQLDB:
      Query error: Lock wait timeout exceeded; try restarting transaction. Query: UPDATE ezcontentobject_tree SET modified_subnode=1256839362 WHERE node_id='1' OR node_id='2' OR node_id='5753' OR node_id='7649' OR node_id='7652' OR node_id='33791'
      [ Oct 29 2009 19:03:33 ] [192.168.1.100] eZDBInterface::commit TRANSID-4d0d9d9f57ae05bf0fa5df7bf28d8199:
      Transaction in progress failed due to DB error, transaction was rollbacked. Transaction ID is TRANSID-4d0d9d9f57ae05bf0fa5df7bf28d8199.

      Steps to reproduce

      Happens very randomly so it is very hard to specify steps to reproduce

        Issue Links

          Activity

          Bertrand Dunogier added a comment -

          This situation is now fixed by using the asynchronous publishing system introduced in eZ Publish 4.5:
          https://github.com/ezsystems/ezpublish/blob/master/doc/features/4.5/ezasynchronouspublisher.txt

          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.

          Geoff Bentley added a comment -

          It doesn't fix the problem - but it does delay it.


            People

            • Assignee:
              Bertrand Dunogier
              Reporter:
              Ivo Luka─Ź
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: